Compiz crashes in Ubuntu 12.04 official release

Asked by ursaminor on 2012-04-27

On fresh install, Ubuntu 12.04 ran Compiz alright. I ran the Update Manager, rebooted and Compiz was good. After installing Additional Drivers, i.e. Nvidia, Compiz crashed and nothing but wallpaper appears. Right-click on screen works and I clicked on Change Desktop Background, then All Settings. I went to Additional Drivers and uninstalled Nvidia. Rebooted and all is well again. Seems like a bug.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-27
Last reply:
2012-04-29
James Womack (james-c-womack) said : #1

I have the same problem, which only arises when the proprietary nVidia drivers are installed. With the open-source nouveau drivers, the problem does not occur.

I am happy to supply additional information, such as hardware information/debug information/system logs if necessary.

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

James Womack (james-c-womack) said : #3

Output of "sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia" (bear in mind that I do not currently have the binary driver installed -- I am using nouveau):

  *-display
       description: VGA compatible controller
       product: C73 [GeForce 7050 / nForce 630i]
       vendor: NVIDIA Corporation
       physical id: 10
       bus info: pci@0000:00:10.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:23 memory:ed000000-edffffff memory:d0000000-dfffffff memory:ee000000-eeffffff memory:7ff00000-7ff1ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux CARBON 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
rc nvidia-173 173.14.30-0ubuntu8.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-cg-toolkit 3.0.0016-0ubuntu1 Cg Toolkit - GPU Shader Authoring Language
ii nvidia-common 1:0.2.44 Find obsolete NVIDIA drivers
ii nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver
ii nvidia-settings-updates 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver

James Womack (james-c-womack) said : #4

Some extra information: with the binary driver installed and active, the lightdm login screen displays fine, but when I try to open an Ubuntu session, compiz throws an error as mentioned above. Also, when I try to open an XBMC session, I get only a blank screen, though the session is clearly working, since I can hear navigation sounds when I press the arrow keys and am able to exit the session using the normal menu options.

Bertalan Fodor (fodber) said : #5

Question 195022 discusses the same problem

Run:

sudo dpkg -P nvidia-173
sudo apt-get --purge remove nvidia-cg-toolkit nvidia-settings nvidia-settings-updates
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

Then reboot

James Womack (james-c-womack) said : #7

Okay, I'll try that.

Further information: It seems to be specific to the 7050 integrated graphics chip. I tried a spare PCI express graphics card (Geforce 8400 GS) and the system functioned without the problems described above.

James Womack (james-c-womack) said : #8

The fix suggested by actionparsnip makes no difference. The system still runs fine on the PCI express GPU (Geforce 8400 GS) and has the same problems with the integrated GPU (Geforce 7050).

Bertalan Fodor (fodber) said : #9

Tried the suggestion on an nforce360a based motherboard with integrated geforce 7025. Compiz still crashes, so I can log in only with Unity 2d.

Bertalan Fodor (fodber) said : #10

This seems to be a problem with nvidia 295.40 driver.
See http://www.nvnews.net/vbulletin/showthread.php?t=178460
You must downgrade to 295.33 or wait for the fix from nvidia.
It's a pity that ubuntu release went out with such a widespread issue.

mr. Ed (mred) said : #11

how can i doing the downgrade?

Bapf (bugs-ubuntu-bapf) said : #12

@mr. Ed

Download and install https://launchpad.net/ubuntu/precise/amd64/nvidia-current/295.33-0ubuntu1 (or the corresponding 32bit package).

You then also may prevent ubuntu from updating it via apt-pinning.

Solved the problem for me.

Can you help with this problem?

Provide an answer of your own, or ask ursaminor for more information if necessary.

To post a message you must log in.