Project in OpenGl with very low fps

Asked by Pedro Cunha on 2012-03-02

Model of graphics card: Nvidia GeForce 425M
Computer: Asus N53JQ
Version of Ubuntu: 11.04

Logged in with Unity Classic

Well, I have an OpenGl project that simply draws a table, a floor and three axes, with rotation implemented by mouse click&drag. Problem is, it is not dragging. Or rather, it is, but with a VERY low fps. Have tried in Ubuntu Classic (no effects) and it runs smoothly. Not sure what the problem is...

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Solved by:
Pedro Cunha
Solved:
2012-03-03
Last query:
2012-03-03
Last reply:
2012-03-02

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

Pedro Cunha (sidner-7) said : #2

I went out on a limb here and decided to go check the version of the Nvidia drivers, since the output of the command you gave me gave me an older version. I noticed that the vsync check box was not ticked, even though it was on CCSM. It solved my problem...

For your benefit, though, here's the output. Could you have found the answer through it?

sidner@sidner-N53Jq:~$ sudo lshw -C display ; lsb_release -a; uname -a; dpkg -l | grep nvidia
[sudo] password for sidner:
  *-display
       description: VGA compatible controller
       product: nVidia Corporation
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:d2000000-d2ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:d000(size=128) memory:d3000000-d307ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
Linux sidner-N53Jq 2.6.38-13-generic #56-Ubuntu SMP Tue Feb 14 12:39:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ii nvidia-common 0.2.30.1 Find obsolete NVIDIA drivers
rc nvidia-current 270.41.06-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
sidner@sidner-N53Jq:~$

Pedro Cunha (sidner-7) said : #3

I mean the VBlank option in OpenGL settings, down at the NVIDIA X Server Settings menu. For some reason it required it to be on as well as the option on CompizConfigure Settings Manager.