Odd output from compiz --replace

Asked by samuel on 2012-02-17

I ran compiz --replace, to see if it was any different from the unity window manager, however, I got the usual expected output, and then this
compiz (core) - Warn: no exact match for ConfigureNotify on 0x3a00090!
compiz (core) - Warn: expected the following changes:
compiz (core) - Warn: sibling: 0xbf857920
compiz (core) - Warn: instead got:
compiz (core) - Warn: x: 0
compiz (core) - Warn: y: 0
compiz (core) - Warn: width: 1600
compiz (core) - Warn: height: 900
compiz (core) - Warn: above: 0
compiz (core) - Warn: this should never happen. you should probably file a bug about this.

Is this serious?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-03-26
Last query:
2012-03-26
Last reply:
2012-02-18

Probably, yes....

What is the output of:

lsb_release -a; uname -a; echo; apt-cache policy compiz

Thanks

Also run:

sudo lshw -C display

What is output there as well, please

Sam_ (and-sam) said : #3

Nothing really dramatic, see the linked bug report.

samuel (samuel-h) said : #4

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Output from lsb_release -a; uname -a; echo; apt-cache policy compiz:
Linux hand-computer 3.0.0-15-generic-pae #26-Ubuntu SMP Fri Jan 20 17:07:31 UTC 2012 i686 athlon i386 GNU/Linux

compiz:
  Installed: 1:0.9.6+bzr20110929-0ubuntu6
  Candidate: 1:0.9.6+bzr20110929-0ubuntu6.1
  Version table:
     1:0.9.6+bzr20110929-0ubuntu6.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
 *** 1:0.9.6+bzr20110929-0ubuntu6 0
        100 /var/lib/dpkg/status
     1:0.9.6+bzr20110929-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
Output from sudo lshw -C display:
 *-display
       description: VGA compatible controller
       product: C61 [GeForce 6150SE nForce 430]
       vendor: nVidia Corporation
       physical id: d
       bus info: pci@0000:00:0d.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:21 memory:fa000000-faffffff memory:e0000000-efffffff memory:f9000000-f9ffffff memory:fbec0000-fbedffff

ok and the output of:

dpkg -l | grep nvidia

Thanks

samuel (samuel-h) said : #6

rc nvidia-173 173.14.30-0ubuntu8 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-common 1:0.2.35 Find obsolete NVIDIA drivers
ii nvidia-current 290.10-0ubuntu1~oneiric~xup1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 290.10-0ubuntu1~oneiric~xup1 Tool of configuring the NVIDIA graphics driver

ok, run:

sudo dpkg -P nvidia-173; sudo apt-get --purge remove nvidia-current nvidia-settings; sudo apt-get --purge autoremove; sudo apt-get clean

Then reboot to use the open source driver, then run:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates ; sudo apt-get update; sudo apt-get install nvidia-current

Reboot to test

samuel (samuel-h) said : #8

Thanks actionparsnip, that solved my question.