keyboard focus

Asked by bill purvis on 2011-12-02

Just up(?)graded to Oneiric and can't find a way to get the keyboard focus to follow the mouse.
I was running Natty, but with Ubuntu Classic which suited me much better!

Bill

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2011-12-03
Last query:
2011-12-03
Last reply:
2011-12-03

Does it happen as a fresh user?

bill purvis (bill-billp) said : #2

Haven't tried that, but I assume that a new user gets the default, i.e. click to change focus.
In earlier releases the config window had a 'window behaviour' panel, which allowed you
to specify 'focus follows mouse', but I can't find any equivalent under Oneiric.

If it is the same as a new user then its a bug, if its as you expect as a new user with vanilla settings then its your old settings causing issues in the new version

bill purvis (bill-billp) said : #4

OK, but how do I fix it? I can't find anything in the Compiz settings that applies. It's driving me up the
wall at present!

Well, did you try the new user, as i advised? What happened?

bill purvis (bill-billp) said : #6

I don't see the point, but yes I have createdd another id and switched to that.
As expected it comes up with 'click to focus', and I can't see any way to change
that.

Its to see if its the application at fault or your settings. Its a simple and free test and if you'd simply complied when requesed, we could have been where we are an hour ago.

Can you give the output of:

lsb_release -a; uname -a; apt-cache policy compiz

Thanks

bill purvis (bill-billp) said : #8

OK, output as follows:

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux bela 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:25:36 UTC 2011 i686 i686 i386 GNU/Linux
compiz:
  Installed: 1:0.9.6+bzr20110929-0ubuntu6
  Candidate: 1:0.9.6+bzr20110929-0ubuntu6
  Version table:
 *** 1:0.9.6+bzr20110929-0ubuntu6 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:0.9.6+bzr20110929-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

Try:

sudo add-apt-repository ppa:gma500/emgd-1.8
sudo apt-get update
sudo apt-get install xorg-emgd emgd-dkms
sudo emgd-xorg-conf

Source:
https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo/

Sorry, wrong post, ignore that :)

bill purvis (bill-billp) said : #11

Thanks, now tell me how to get out of it!

OK, I know you're doing your best, but it has trashed my system. At least - I can't get
it to bring up X11. I'm only managing this as I have another system and can log in via ssh
to run Firefox. I tried booting in recovery mode and ran apt-get remove xorg-emgd and emgd-dkms
but that is obviously not enough. How can restore the X11 server to working?

Best Sam_ (and-sam) said : #12

Maybe first try to remove all there is regarding 'emdg'.
e.g.
dpkg -l emdg* |grep ii
https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo/#Driver_Removal

In case boot into virtual console: ctrl+alt+f1
Try to reinstall or reconfigure your origin graphical driver, if necessary reinstall or reconfigure kernel images.

Answer to orig. subject 'focus follows mouse':
Install CCSM (compizconfig-setttings-manager).
In the 'general' options is a tab 'focus & raise behaviour', unmark focus with mouse-click options.
Due to global menu the user needs to curve around other open apps in order to reach the menu of the one which has the focus.
Bug #674138

bill purvis (bill-billp) said : #13

Finally got a working system again - I removed all of xorg and reinstalled. I then tried restarting gdm
but nothing appeared. Finally tried a reboot and it all came back! Now to try CCSM, finger crossed.

bill purvis (bill-billp) said : #14

Thanks Sam_, that solved my question.