Unity 3D poor performance after upgrade

Asked by EliCoten on 2011-10-23

In Natty, I eventually managed to get a stable system working, with reasonable/good desktop effects performance. Now I've just upgraded to Oneiric and the performance has dropped significantly. Unity2D session seems to work ok, but Unity3D is almost unusably slow. There is a lot of lag and the screen seems to be delayed when it updates (e.g. if I'm typing, the letters appear a while after I press the keys).

Any ideas?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-10
Last reply:
2011-11-20

What video chip??????

EliCoten (launchpad-elicoten) said : #2

Ati Radeon X1250 (RS690)

If there is any more specific information, feel free to post commands to run and I'll post the output.

Thanks very much

Let's see what video drivers you're running. Please post the output of this command:

sudo lshw -C video

EliCoten (launchpad-elicoten) said : #4

It seems to be a little better today - I'm not sure why. But it's still not as fast as it was before I upgraded. To give an example, the compiz-benchmark plugin reports an average of around 18fps depending on what else is going on (goes down to about 11 and up to about 22fps)
I know GLXGears isn't supposed to be used as a benchmark, but it reports around 35fps when previously I think it was closer to 60fps.
Anyway, here's the output of that command:
  *-display
       description: VGA compatible controller
       product: RS690M [Radeon X1200 Series]
       vendor: ATI Technologies Inc
       physical id: 5
       bus info: pci@0000:01:05.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=64
       resources: irq:18 memory:80000000-87ffffff memory:8c200000-8c20ffff ioport:5000(size=256) memory:8c100000-8c1fffff

Thanks very much

You are using the opensource driver, have you (or can you) enable the proprietary driver?

EliCoten (launchpad-elicoten) said : #6

According to http://support.amd.com/us/gpudownload/linux/Legacy/Pages/radeon_linux.aspx?type=2.7&product=2.7.2.3.2&lang=English, I have to install a distro prior to Feb 2009 to use that driver, but is there another one I could try? Or could I use it despite that notice?

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

EliCoten (launchpad-elicoten) said : #8

I'm still having the problem though. Why was it expired?

It was open for 15 days with no activity, as it says.....

You could use an xorg.conf to get better performance.

EliCoten (launchpad-elicoten) said : #10

How would I use xorg.conf to get better performance? The performance was fine before I upgraded...?

EliCoten (launchpad-elicoten) said : #11

Any ideas? Still struggling with very low FPS, though it was much better before I upgraded.

Could try a clean install. Can often help

EliCoten (launchpad-elicoten) said : #13

I'm not sure about that one. I suppose I could try a liveCD, which would be akin to a clean install but I'd rather not go down that route.

Since the proprietary driver is not available for you, it seems likely that you will not be able to get a fix for this problem (besides by reinstalling the older Ubuntu release that had worked well). However, you could try changing the video mode (resolution, color depth, and/or refresh rate).

You could also try logging on as a different user, in case somehow the problem is user-specific, though that seems unlikely. (If you only have one user account, you can create a second one for testing purposes, or use Guest.)

Or you could just use Unity 2D.

Can you help with this problem?

Provide an answer of your own, or ask EliCoten for more information if necessary.

To post a message you must log in.