Is is possible to eliminate all tooltips?

Asked by Paul Graham on 2011-08-23

I'd like to eliminate all tooltips (those annoying bubble-help thingies that appear when you hover the mouse over a menu item or tab). Is there a way to do this? I found a reference to eliminating gnome tooltips using the configuration editor, but this only works for gnome. How about adobe, firefox, etc? Is there a single place in the OS or the X server that can disable tooltips generally?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-23
Last reply:
2011-08-23

Hi, you have removed the tooltip from /apps/panel/global/tooltips_enabled yes?
For the other tooltip, try to do this:
http://ubuntuforums.org/showpost.php?p=9500316&postcount=2

Here is the image if you aren't on ubuntu forum:
http://ubuntuone.com/p/1CNr/

Here is the way for do what i've sayd in the previous message:
Open your Compiz Config Settings Manager, enable "Opacity, Brightness and Saturation" under "Accessibility". Click on the button to go into the settings. Under the "Opacity" tab go down to "Window Specific Settings" and click "Add". Type "Tooltip" and slide the opacity down to zero. Click "Close".

Paul Graham (paulbgraham) said : #3

Enrico,

Thanks for the quick reply. Yes, I have already disabled some
tooltips by turning off /apps/panel/global/tooltips_enabled.

I tried your suggestion of reducing the opacity of "Tooltip" windows
in compiz, to 5%. However, I see no difference in the tooltips from
programs like acrobat. Maybe they just code their own tooltips
without regard to OS settings?

Paul

On Tue, Aug 23, 2011 at 3:56 PM, Enrico "eNry" Carafa
<email address hidden> wrote:
> Your question #168990 on software-center in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/software-center/+question/168990
>
> Enrico "eNry" Carafa proposed the following answer:
> Here is the way for do what i've sayd in the previous message:
> Open your Compiz Config Settings Manager, enable "Opacity, Brightness and Saturation" under "Accessibility". Click on the button to go into the settings. Under the "Opacity" tab go down to "Window Specific Settings" and click "Add". Type "Tooltip" and slide the opacity down to zero. Click "Close".
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+source/software-center/+question/168990/+confirm?answer_id=1
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/software-center/+question/168990
>
> You received this question notification because you asked the question.
>

Have you tried the solution of the 2nd message?
Why you use Acrobat? It's the PDF reader right? The preinstalled software is better then him.

Anyway, the tooltip from other applications goes away?

Paul Graham (paulbgraham) said : #5

Enrico,

Yes, I just changed the opacity of "Tooltip" windows to 5% in the
compiz configuration manager. This has no effect on acrobat tooltips.
 I restarted acrobat to make sure.

Maybe these aren't tooltips from acrobat. I have an acrobat window
with multiple pdfs open. Each pdf has a tab. What I see, and do not
like, is this little window that pops up with the name of the file in
the tab. This window may not really be a tooltip. It is decorated by
the window manager with a resize corner, so perhaps it is some kind of
hack to emulate tooltips.

I use acrobat because evince has some problems that I don't know how
to work around. For one thing, evince always comes up for me with a
thumbnails panel. I don't know how to prevent this. It also always
produces, for me, lots of warnings like this:

(evince:10429): Gtk-WARNING **: Attempting to store changes into
`/home2/pgraham/.local/share/recently-used.xbel', but failed: Failed
to create file '/home2/pgraham/.local/share/recently-used.xbel.NG540V':
Permission denied

(evince:10429): Gtk-WARNING **: Attempting to set the permissions of
`/home2/pgraham/.local/share/recently-used.xbel', but failed:
Permission denied

Paul

On Tue, Aug 23, 2011 at 4:31 PM, Enrico "eNry" Carafa
<email address hidden> wrote:
> Your question #168990 on software-center in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/software-center/+question/168990
>
>    Status: Open => Answered
>
> Enrico "eNry" Carafa proposed the following answer:
> Have you tried the solution of the 2nd message?
> Why you use Acrobat? It's the PDF reader right? The preinstalled software is better then him.
>
> Anyway, the tooltip from other applications goes away?
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+source/software-center/+question/168990/+confirm?answer_id=3
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/software-center/+question/168990
>
> You received this question notification because you asked the question.
>

I'm sorry but I think that you can't remove the tooltip from Acrobat Reader.
Try to move the option in Compizconfig from 5% to 0%.

Can you help with this problem?

Provide an answer of your own, or ask Paul Graham for more information if necessary.

To post a message you must log in.