Codeblocks package out of date?

Asked by Steve Wilson on 2019-05-31

Would it be fair to say that the Codeblocks package here is out of date? From what I've seen, the latest version here is 16.01, whereas the developers are on 17.12. I _have_ actually managed to install a more up-to-date version on my Mint/XFCE machine by adding an alternative repo to my sources.list, but I still have problems updating the related codeblocks-contrib package. That depends on hunspell-1.4-0 whereas the latest version (already on my machine) is hunspell-1.6-2. Being a Linux newbie, I am unclear as to exactly why I should be unable to revert the version of hunspell (having tried) and indeed why it should be necessary in the first place. I'm guessing that the codeblocks-contrib package needs to be updated to use current versions of its dependencies, but I'm not sure who it is that takes care of such matters. Sorry for the vagueness here, but as I said before, I am relatively inexperienced in the Linux world.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu codeblocks Edit question
Assignee:
No assignee Edit question
Last query:
2019-05-31
Last reply:
2019-05-31
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output that you receive for the commands

uname -a
lsb_release -crid
apt-cache policy codeblocks codeblocks-contrib libcodeblocks0

You have to be aware that Ubuntu is taking over packages from Debian to avoid double packaging work, and Debian also has only version 16.01
There is already a request in the Debian bug tracker to update the version, https://bugs.debian.org/886062

Steve Wilson (ed0cbaf) said : #2

Thanks for replying. Here's the output requested ...

steve@StinkPod-T410:~$ uname -a
Linux StinkPod-T410 4.15.0-50-generic #54-Ubuntu SMP Mon May 6 18:46:08 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
steve@StinkPod-T410:~$ lsb_release -crid
Distributor ID: LinuxMint
Description: Linux Mint 19.1 Tessa
Release: 19.1
Codename: tessa
steve@StinkPod-T410:~$ apt-cache policy codeblocks codeblocks-contrib libcodeblocks0
codeblocks:
  Installed: 17.12svn11628
  Candidate: 17.12svn11628
  Version table:
 *** 17.12svn11628 999
        999 https://apt.xaviou.fr stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     16.01+dfsg-2.1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
codeblocks-contrib:
  Installed: (none)
  Candidate: 17.12svn11628
  Version table:
     17.12svn11628 999
        999 https://apt.xaviou.fr stretch/main amd64 Packages
     16.01+dfsg-2.1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
libcodeblocks0:
  Installed: 17.12svn11628
  Candidate: 17.12svn11628
  Version table:
 *** 17.12svn11628 999
        999 https://apt.xaviou.fr stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     16.01+dfsg-2.1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
steve@StinkPod-T410:~$

Manfred Hampl (m-hampl) said : #3

Sorry, but we cannot help further.

You are running Linux Mint, and you have installed codeblocks from some foreign source.

Both items make your question outside the scope of Ubuntu support.

Manfred Hampl (m-hampl) said : #4

Manfred Hampl suggests this article as an answer to your question:
FAQ #3041: “No support for Linux Mint”.

Can you help with this problem?

Provide an answer of your own, or ask Steve Wilson for more information if necessary.

To post a message you must log in.