Vendor data cache being referenced on new instance

Asked by Gregory Bonk on 2018-04-19

I'm working on Centos 6.9, and since I have not been able to find a RPM of Cloud Init 18.2 I decided to build one my self in AWS.

I run the following....

python setup.py build

then

python setup.py install --init-system sysvinit

then I do some chkconfig to enable the services. Cloud init runs great.... the first time.

The second time I launch a new AMI I get the following error messages

2018-04-18 21:40:15,473 - util.py[DEBUG]: Running command ['ip', '-4', 'addr', 'show'] with allowed return codes [0] (shell=False, capture=True)

2018-04-18 21:40:15,476 - __init__.py[DEBUG]: unable to do any work for renaming of [['06:20:32:31:e3:9c', 'eth0', 'vif', None]]

2018-04-18 21:40:15,572 - stages.py[WARNING]: Failed to rename devices: [nic not present] Cannot rename mac=06:20:32:31:e3:9c to eth0, not available.

2018-04-18 21:40:15,572 - stages.py[DEBUG]: not a new instance. network config is not applied.

EARLIER... in the debug log I see a few clues.

handlers.py[DEBUG]: start: init-local/check-cache: attempting to read from cache [check]
util.py[DEBUG]: Reading from /var/lib/cloud/instance/obj.pkl (quiet=False)
util.py[DEBUG]: Read 8117 bytes from /var/lib/cloud/instance/obj.pkl
util.py[DEBUG]: Reading from /run/cloud-init/.instance-id (quiet=False)
util.py[DEBUG]: Read 20 bytes from /run/cloud-init/.instance-id
stages.py[DEBUG]: restored from cache with run check: DataSourceEc2
handlers.py[DEBUG]: finish: init-local/check-cache: SUCCESS: restored from cache with run check: DataSourceEc2

BUT this is a new instance and it shouldn't even look at the cache or .instance-id file. The instance ID file does not contain the actual AWS Instance id

Is there a way to disable the caching mechanism, or is there something else since I'm building cloud-init from source ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cloud-init Edit question
Assignee:
No assignee Edit question
Solved by:
Gregory Bonk
Solved:
Last query:
Last reply:

This is Ubuntu support. Not Centos. I suggest you post here:
https://www.centos.org/forums/

Gregory Bonk (gbonk) said : #2

Thanks, I wasn't sure.