backporting / libical

Asked by Martin on 2018-09-13

I'm trying to backport the package defined here.

http://http.debian.net/debian/pool/main/c/claws-mail/claws-mail_3.17.1-1.dsc

Which is exactly the same package / build deps as :

http://archive.ubuntu.com/ubuntu/pool/universe/c/claws-mail/claws-mail_3.17.1-1.dsc

Now, I know latest claws-mail depends on libical > 2
and both the deps above shows on libical-dev, instead of
libical2-dev so I wonder how ubuntu's able to build claws-mail
package !?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu claws-mail Edit question
Assignee:
No assignee Edit question
Solved by:
Martin
Solved:
2018-09-17
Last query:
2018-09-17
Last reply:
2018-09-13
Martin (mh-3) said : #1

Even more confusing, when you compare :
http://archive.ubuntu.com/ubuntu/pool/universe/libi/libical/libical_2.0.0-4.dsc which produce libical2-dev
and
http://cdn-fastly.deb.debian.org/debian/pool/main/libi/libical/libical_2.0.0-0.5.dsc which produce libical-dev

I might understand claws could build in debian, but I don't understand how can it be in Ubuntu...

Manfred Hampl (m-hampl) said : #2

To which Ubuntu release do you want to backport claws-mail?

You have to be aware of the following:

claws-mail version 3.17.1-1 is in Ubuntu cosmic.
In Ubuntu cosmic the package libical-dev is provided with the source package "libical3", which fulfills the dependency "libical > 2" that you mentioned.

In older Ubuntu releases like xenial the package libical-dev provided with the "libical" source package and does not fulfill "libical > 2".

Is the required libical version "> 2" or is it ">= 2"?

If you want to backport the current version of claws-mail to xenial, you probably have to backport a sufficiently high version of libical/libical2/libical3 to xenial first.

Martin (mh-3) said : #3

Thanks for detailing up.
I already backport'd with success libical v2 from Cosmic to Xenial, which produce libical2-dev (not libical-dev).

So I'm pretty sure that if I change the control file of claws-mail, and update the dep from libical-dev to libical2-dev it might work.

*But* then, how can it be, that only libical v2 from cosmic produce libical2-dev ?
Is it that libical v3 from Cosmic produce libical3-dev or is it that libical v2 from cosmic *should* have be made to produce libical-dev ? might it be because libical v2 is not binary compatible with v1 ?

This being said, I'm going to backport libical3 to Xenial so I won't be forced to change claws's control file.

Thanks

Manfred Hampl (m-hampl) said : #4

I do not know any details about the history of the libical*-dev packages, but the changelog tells (among others):

libical 2.0.0-2 * Rename libical-dev to libical2-dev. libical-dev is now provided by libical3-dev. (08 Dec 2017)

libical3 3.0.1-2 * libical3-dev: Provide libical-dev. (08 Dec 2017)

libical3 3.0.1-3 * Rename libical3-dev to libical-dev, now that libical only builds libical2-dev. (09 Dec 2017)

Quite a complicated case, involving three different names: libical-dev, libical2-dev and libical3-dev (and finally back to libical-dev).

Martin (mh-3) said : #5

Hi Manfred,
Thank you for your valuable help.
I've been able to backport libical3 and claws-mail almost as-is.
Cheers !