ClamAV engine will not update

Asked by Margaret Page on 2012-01-06

I have Ubuntu 10.10, KlamAV 0.96.5, and ClamTK 4.36. My KlamAV will not update. When I pull up the KlamAV window I can't read what it says, but I tried gksudo klamav it says that my version of ClamAV engine is outdated. When click on the site it brings up that it starts KlamAV and I click on Download KlamAV, but it never brings anything up to download. At the very end of the terminal it reads KCrash: Application 'klamav' crashing... Could not find 'drkonqi' executable. KCrash cannot reach kdeinit, lauching directily. Still after this nothing happens. What do I need to do to get my KlamAV to update?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu clamav Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-01-07
Last query:
2012-01-07
Last reply:
2012-01-07
Margaret Page (idrthrbridin) said : #1

It says in the box when it would show the different updates it is downloading, Hint: The database directory must be writeable for UID 0 or GID 0.

Try:

sudo add-apt-repository ppa:ubuntu-clamav/ppa; sudo apt-get update; sudo apt-get -y upgrade; sudo freshclam

Does that help?

If you are using Gnome you don't need KlamAV, clamTk is the GTK frontend and should be run with:

gksudo clamtk

To update the defs outside of the gui, run:

sudo freshclam

Which I added to the command to run and should make things ok

Margaret Page (idrthrbridin) said : #3

It also says when I click on Download KlamAV
X Errror: BadWindow (invalid Window parameter) 3
  Major opcode: 7
  Minor: opcode 0
  Resource id: 0x4500023

Now it comes up with WARNING: getpatch: Can't download...an whatever it is trying

The command I gave will update you just fine

Margaret Page (idrthrbridin) said : #5

Thanks actionparsnip, that solved my question.

Jaybok (jaybok) said : #6

Thank you! actionparsnip, that command did the trick for me too.