Couldnt install tar in natty (ubuntu 11.04)

Asked by Caesium Chloride on 2011-08-18

Tried installing clam anti virus from tar.gz file.
Could configure as a root user with chmod +x ./configure. But the make never works. Tried the same with tar for vlc, Vuze.

I have 'alien', 'build-essential' installed and also tried with 'easy package installer' http://www.sourceforge.net/projects/epiinstaller
 which helps install tar, rpm with help of alien, 'build-essential'.

root@ubuntu:/media/Softwares/Linux/OOO330_m20# chmod +x ./configure
root@ubuntu:/media/Softwares/Linux/OOO330_m20# make
make: *** No targets specified and no makefile found. Stop.

I couldnt install though Ubuntu Software Center. Please help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu clamav Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-18
Last reply:
2011-08-18
mycae (mycae) said : #1

1) Why are you building from source? Typically this is a difficult thing to do -- that is why packages such as debs are available in the repository. If you want more up to date software than the defaults, use a PPA.

2) The commands you execute do not do what you want. This command:

chmod +x ./configure

Simply instructs the OS to allow the shell to run the script as a program. It does not run it. You have to use

./configure OPTIONS

Then you should get a whole bunch of stuff, at the end of which will say "creating makefiles", if it succeeds. Then you can run

make

You said you couldn't install through the Software Center. What happens when you try? (The package for Clam AntiVirus is called clamav.)

Can you help with this problem?

Provide an answer of your own, or ask Caesium Chloride for more information if necessary.

To post a message you must log in.