Install/Uninstall fail, cannot find /etc/avg.conf

Asked by Alex Bedker on 2011-04-23

I'm trying to install the free version of AVG, and the installation didn't work. The program does not function. Reinstallation and uninstallation fail due to...
ERROR: Could not find /etc/avg.conf

invoke-rc.d: initscript avgd, action "stop" failed.

dpkg: error processing avg85flx (--remove):

 subprocess installed pre-removal script returned error exit status 6

Errors were encountered while processing:

 avg85flx
...this is using software center. When attempting to reinstall I get a different error...
There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks. Please report this error at http://launchpad.net/aptdaemon/+filebug and retry.
...retrying does not work, and there were no solutions to this bug at last check. I even tried using Synaptic Package Manager to remove it, that failed as well...
E: avg85flx: subprocess installed pre-removal script returned error exit status 6
...looking at details shows the same error that occurred while trying to remove with the software center.

How do I fix this? I would settle for just getting it removed, then I can try a different install procedure.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu clamav Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-04-25
Last query:
2011-04-25
Last reply:
2011-04-24

http://ubuntuforums.org/showthread.php?t=629903

I personally suggest you try clamav, it rocks (imho)

sudo add-apt-repository ppa:ubuntu-clamav/ppa; sudo apt-get update; sudo apt-get -y install clamav clamtk; sudo freshclam

Will give an updated AV suite.

Alex Bedker (abedker) said : #2

The solution of using Synaptic doesn't work for me. I get

E: avg85flx: subprocess installed pre-removal script returned error exit status 6

and details show that it failed to find /etc/avg.conf

Any other ideas on removing it? Is removal even necessary if I go with clamav?

can you give the output of:

sudo find / -name "avg.conf"

It will take a while to run, When the prompt gives you control back then it is finished. What is output

Thanks

Alex Bedker (abedker) said : #4

It ouputs...

/opt/avg/avg8/etc/avg.conf

cool. Try:

sudo ln -s /opt/avg/avg8/etc/avg.conf /etc/avg.conf

Then retry what cause the initial error

Alex Bedker (abedker) said : #6

That worked great. Thanks for your help.