Update ClamTK antivirus engine

Asked by JOHN on 2010-11-26

The GUI menu for ClamTK indicates my Antivirus engine is outdated. I have been unable to locate the latest version.

The GUI indicates it is out of date (version 4.29) but when I try to download and install 4.30, I get a message saying it is already installed. If it is, it is not displayed on the ClamTK Virus Scanner GUI menu.

I'm using Ubuntu 10.04

John

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu clamav Edit question
Assignee:
No assignee Edit question
Solved by:
JOHN
Solved:
2010-11-27
Last query:
2010-11-27
Last reply:
2010-11-26
mycae (mycae) said : #1

Somethings not right.

Natty packages 4.30, but natty is unreleased. Maverick packages 4.26.
https://launchpad.net/ubuntu/maverick/+source/clamtk

If clamtk is telling you this, then it is phoning home -- which it should not do, at the very least for this reason. Whilst the upstream project may have been modified, and is not up-to-date, the ubuntu package is probably up-to-date.

clamtk 4.30 has not been provided as an update for any released ubuntu version.
https://launchpad.net/ubuntu/+source/clamtk

mycae (mycae) said : #2

Are you subscribed to any PPAs?

JOHN (jlumbtx) said : #3

Sorry. Don't know what a PPA is, so I probably don't subscribe.

What about updating the antivirus engine?

John

Andre Mangan (kyphi) said : #4

From FAQ Clamtk:

"Why is the GUI telling me the engine is outdated?

ClamTk is only a GUI for ClamAV antivirus. To update the engine, your distribution needs to release an updated version of ClamAV itself. A polite reminder to whoever maintains ClamAV for your distribution may prompt them to do so."

For Clamtk, download the "clamtk_4.30-1_all.deb" file for Ubuntu from: http://sourceforge.net/projects/clamtk/

JOHN (jlumbtx) said : #5

Andre,
Thank you. I tried installing ClamTX again and this time it worked. Still need the new antivirus engine. I'll pester Ubuntu.

Thanks ll all for your help