CIFS filesystem not supported by the system - Ubuntu 12.04 unstable core

Asked by Stephen Le Bas on 2012-04-05

I have seen this error reporterd before, howeverf I cannot locate any answers - I recall this was noted as ab issue on the linaro build?

When trying to mount a windows share I get the following error

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I am running the following versio of Ubuntu 12.04 core on a PandaBoard ES Rev B1

Linux PandaCore1 3.2.0-1411-omap4 #14-Ubuntu SMP PREEMPT Tue Mar 27 16:28:06 UTC 2012 armv7l armv7l armv7l GNU/Linux.

To the absolut best of my understanding I have installed all necessary packages - I have also update and upgraded the installation.

Are there any tricks to getting smaba/cifs support sorted out - keen to know what I am missing?

Thanks,

Regards,

Stephen Le Bas

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cifs-utils Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen Le Bas
Solved:
2012-04-15
Last query:
2012-04-15
Last reply:
2012-04-06
luuminh (taolao-q) said : #1

install -> smbfs

Stephen Le Bas (meyevue) said : #2

smbfs is installed

I could try removing and reinstalling it....

Stephen Le Bas (meyevue) said : #3

I am reasonably experienced in getting Samba/cifs sahres mounted across a range of linux platofrms. I have a happy beagle bone running ubuntu 11.10 accessing cifs shares. I had the problem desribed above with a linaro version of Ubuntu 12.04 desktop for armhf on the same Panda board. I installed a beta version of ubuntu from the precise Pangolin desktop image version of Ubuntu 12.04 - it can mount cifs - but there appears to be some drama with it in that the system freezes after being on for a while (I have raise questions/bugs re. this but have not yet received a definitive answer/solution) - I suspect that this may be an issue with gui and moving into power save mode - that's when I decided to install the 12/04 Ubuntu core to get the gui out of the picture - systenm stable now byt won't mount cifs shares! :| - and this is where I am at. I have even gone so far as to start re-installing the various compoenents of samba, cifs-utils, smbclinet, and smbfs from the debian discrete packages rather that cis the apt-get... all to no avail - I am sure I must be doing something quite silly - but I just can't spot it - hence my inquiry hoping someone can open my eyes to my error! :)

Thanks,

Regards,

Stephen Le Bas

Stephen Le Bas (meyevue) said : #4

For completeness, I removed and reinstalled smbclient and smbfs - the same problem is still manifest.

luuminh (taolao-q) said : #5

can I see the your fstab

Jeet (gour-jitendrasingh) said : #6

provide output of
cat /etc/fstab

Stephen Le Bas (meyevue) said : #7

I have not initialised my fstab as yet? Itjust has a comment line.

Is this relevant if I am explicitly stating the mount type.? - ie. mount -t cifs //192.168.0.6/Docs /mnt/tmp

I can mount an ext4 file system successfully.

ie. mount -t ext4 /dev/sad1 /mnt/tmp works fine.

Regards,

Stephen Le Bas

Stephen Le Bas (meyevue) said : #8

....also - for completeness fstab contents as requested earlier

# UNCONFIGURED FSTAB FOR BASE SYSTEM

Stephen Le Bas (meyevue) said : #9

I just added the line

proc /proc proc nodev,noexec,nosuid 0 0

to the /etc/fstab (I mimicked the line from another ubuntu linux system)

Given this is a file system related mount - I thought it may help, but unfortunately not....still the same mounting error described above.

Any help here would be much appreciated!

I did try setting up an 11.10 core version on SD card to see whether it may be a 12.04 kernel problem - but I could not mount a cifs share on it either - same error as in my first posting - so I must still missing something in my setup......

Thanks.

Regards,

Stephen Le Bas

luuminh (taolao-q) said : #10

surely you have admin right on windows PC., and tmp directory is exist in /mnt

try this on Terminal :
sudo mount -t cifs //192.168.0.6/Docs /mnt/tmp -o username=(your user name on windows PC)

Stephen Le Bas (meyevue) said : #11

I have all the necessary rights and all relevant directories exist. The particular piece of application software that mountths windows share in question runs fine on Fedora 13,14,15, Ubuntu 11.10 on x86 and also Centos linux machine. In addition to this it has worked successfully on a BeagleBone running Ubuntu 11.10. It has alaso successfully run on other versions of Ubuntu 12.05 for armhf desktop image on this PandaBoard ES Rev1, however the desk top image seems to have an issue where it freezes after an indeterminate period of running - hence my desire to try the core ubuntu 12.04 - which behaves better in terms of not freezing, however it won't let me mount the cifs share I need to for my application.

As mentioned above I also had this issed on a linaro version of ubuntu 12.04 and others also seemed tohave this issue - I have not seen the resolution to that particular probhlem as yet.

I deeply suspect that I have not quite configured my core 12.04 file system correctly ad yet given that I see the problem in both 11.10 and 12.04 versions of ubuntu armhf and armel.

...hence looking for someone to shine light on my omission on configuration/......

In terms of the mounting operation, when attempting to mount the cifs share, I am prompted for my password and it is after this that the error message is displayed.

The aspect of the error messaging I am focusing on is

"mount error: cifs file system not supported by the system" as this seems to indicate that I am missing something with the installed core system.

Also the device being mounted in a cifs share on a NAS device, not on a windows machine per se. and as mentioned above I have successfully mounted the share in questions on a range of different linux systems.

Regards,

Stephen Le Bas

Ross Peoples (deejross) said : #12

I'm having the exact same problem on Ubuntu 11.10. I can't believe no one has noticed this issue until now. It's been a problem since Ubuntu 11.10 was released. I have tried to reinstall smbfs and cifs-utils with no success. I also install smbclient for kicks and it still doesn't work.

Interestingly, if you do apt-get remove cifs-utils, then try to mount, you get this:

mount: unknown filesystem type 'cifs'

And reinstalling it gives this:

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I guess I'll have to continue using sshfs for everything.

Stephen Le Bas (meyevue) said : #13

Gi'day Ross,

I am glad to hear that someone else was having the same issue - I was beginning to think I was going mad! I also went through a similar process in removing and reinstalling cifs and sama to see whether the messages changes - and they did, much as you found. I only had this issue with Ubuntu core for OMPA4 - I had previously installed a desktop image for OMAP4 and did not have this problem, however I found that the desktop image system hung after being on for a while - so I figured that there was some display hibernate issue that was freezing things?? or other issue??? - I posted about that too and found no solution - so I ditched the desktop image and went for the core image and this is when I experienced the cifs issues. I had also instaled a minimal ubuntu image on a BeagleBone and had no problmes with cifs - so I figured that it must have been some simple omission from the ubuntu core for omap4 - 12.04.

I actuallly had some success in solving this problem last week - I have also posted some relevant info to another thread I started re. trying to build modules. (see. https://answers.launchpad.net/ubuntu/+source/cifs-utils/+question/192875).

However for completeness in this thread, here is what I found:

If you go and look in the directory (on your embedded device (in my case this is a panda board ES Rev B1))

/lib/modules/3.2.0-1411-omap4/kernel/fs/cifs you should see a file cifs.ko.

(note the version number string for your embedded system can be round using uname -r) If this file is not there then this is most likely the root of the problem. This is the cifs module (cifs linux driver). My frustration in the other theread I openned, 192875, derived from me not being able to find this module anywhere easy to download. I eventually solved this two ways i) I still had the desktop image on flash so I simpy copied that into my ubuntu core SSD file system. In the process of getting cifs going I also found that I needed a couple of cryto moduels for cifs to work.

Have a look in /lib/modules/3.2.0-1411-omap4/kernel/crypto and see if des_generic.ko and md4.ko are present - if not you will have to get copies of these too. Again, I had these on the desktop image I had on SD card.

Not too that once the modules have been installed you have to run depmod -a on the target embedded hardware to generate the file modules.dep which resides in the directory /lib/modules/`uname -r`, Once the depmod comand has been executed you will see references to the new modules in the modules.dep file. The references in the modules.dep wil be in the form

kernel/fs/cifs/cifs.ko:
kernel/crypto/md4.ko:
kernel/crypto/des_generic.ko:

As an academic and educational exercise I also went through the process of building these modules from scratch - which took a bit of mucking around, and for completeness, I did this both on the native hardware and then in a cross compilation environment (i686 Ubuntu 11.10).. these modules also worked successfully when copied onto the Panda Board.

Not sure whether what you are exprienceing is the same issue or not, but I hope this helps in some way.

Regards,

Stephen Le Bas

For me the cifs.ko file was existing, but somehow did not match any more because the kernel was updated since I last rebooted

The output of "sudo modprobe cifs" was helpful and for me a reboot to the latest kernel version solved the problem.