snap chromium won't start on Ubuntu 14.04

Asked by Toshi on 2020-07-24

Hello guys, can anyone give me advice?
I'm a newbee to snap command.
I have tried to use snap chromium(channel=candidate/vaapi) but failed.
Error messages I got are here;

----------------------------------------------------------------------
toshiomi@toshiomi-Inspiron-1210:~$ snap run chromium
Failed to move to new namespace: PID namespaces supported, Network namespace supported, but failed: errno = Operation not permitted
Trace/breakpoint trap (core dumped)
toshiomi@toshiomi-Inspiron-1210:~$ snap run chromium --no-sandbox
[6015:6015:0725/010834.753435:ERROR:browser_main_loop.cc(1469)] Unable to open X display.
----------------------------------------------------------------------
Something goes wrong, but no idea how to dig this problem...
DEB version chromium-browser and other X commands work well.

Info of my box is here, (uname -a; snap list --all; snap info chromium)
----------------------------------------------------------------------
toshiomi@toshiomi-Inspiron-1210:~$ uname -a
Linux toshiomi-Inspiron-1210 4.4.0-142-generic #168~14.04.1-Ubuntu SMP Sat Jan 19 11:28:33 UTC 2019 i686 i686 i686 GNU/Linux
toshiomi@toshiomi-Inspiron-1210:~$ snap list --all
Name Version Rev Tracking Publisher Notes
chromium 84.0.4147.89 1230 candidate/… canonical* -
core18 20200707 1878 stable canonical* base
gtk-common-themes 0.1-36-gc75f853 1506 stable canonical* -
toshiomi@toshiomi-Inspiron-1210:~$ snap info chromium
name: chromium
summary: Chromium web browser, open-source version of Chrome
publisher: Canonical*
contact: https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bugs?field.tag=snap
license: unset
description: |
  An open-source browser project that aims to build a safer, faster, and more stable way for all
  Internet users to experience the web.
commands:
  - chromium.chromedriver
  - chromium
snap-id: XKEcBqPM06H1Z7zGOdG5fbICuf8NWK5R
tracking: candidate/vaapi
refresh-date: yesterday at 23:37 JST
channels:
  stable: 83.0.4103.116 2020-07-01 (1214) 167MB -
  candidate: 84.0.4147.89 2020-07-15 (1230) 169MB -
  beta: 84.0.4147.85 2020-07-09 (1223) 168MB -
  edge: 85.0.4183.26 2020-07-17 (1233) 170MB -
installed: 84.0.4147.89 (1230) 169MB -
----------------------------------------------------------------------

Thanks,

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu chromium-browser Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-07-25
Last query:
2020-07-25
Last reply:
2020-07-24

If you press ALT+F2 and run:

chromium-browser

Does it run OK?

Best Manfred Hampl (m-hampl) said : #2

Support for Ubuntu 14.04 has already ended a year ago (except for ESM which is a paid option for security updates for selected server packages), see https://wiki.ubuntu.com/Releases

And for your error message:
A web search lists https://github.com/jessfraz/dockerfiles/issues/65#issuecomment-266532289
Maybe that helps.

Toshi (toshiomi-moriki) said : #3

Thanks for your replies.
Finally I have found it works on 16.04 LTS. ;-)

Toshi (toshiomi-moriki) said : #4

Thanks Manfred Hampl, that solved my question.