Webcam logitech - need to brighten picture

Asked by cpysang on 2009-09-12

I installed Cheese, and I do see a picture however it is very dark and I can barely make-out any features. Is there someway I can improve the quality? The usb webcam is a Logitech QuickCam Go which it seems works with the Express Pluss drivers.

The output of lsusb:
Bus 001 Device 002: ID 03f0:5d11 Hewlett-Packard Photosmart C5200 series
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 046d:092f Logitech, Inc. QuickCam Express Plus
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 03f0:0024 Hewlett-Packard KU-0316 Keyboard
Bus 003 Device 002: ID 046d:c518 Logitech, Inc. MX610 Laser Cordless Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Question information

English Edit question
Ubuntu cheese Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
2009-09-25 (mylie972) said : #1

je suis desolee mais je ne comprend ps l'anglais et je n'arrive pas a ouvrir la lectue pour ecouter

cpysang (cpysang) said : #2

Sorry my French is so bad it is non existent. Can you please translate to English?

john (no2498) said : #3

this worked on my cam if it dont work dont save it

OK, this worked great for me, but let me neatly sum this all up.

I have a Sunplus Technology Co., Ltd Flexcam 100 (shabby little cam I got as a free gift when ordering contact lenses), so for other cameras, you'll want to adjust to different values.

My optimal settings were:
Gamma: 4
Red: 290
Green: 310
Blue: 315

Go to the the Linux Video settings directory:
cd /sys/module/gspca/parameters/

EVERY FOLLOWING COMMAND MUST BE RUN AS ROOT! (sudo doesn't handle the ">" redirection stuff elegantly without weird escaping, which I haven't mastered yet)

sudo su

And echo new values to the gamma and color files:
echo 4 > /sys/module/gspca/parameters/gamma
echo 290 > /sys/module/gspca/parameters/GRed
echo 310 > /sys/module/gspca/parameters/GGreen
echo 315 > /sys/module/gspca/parameters/GBlue

After tweaking with these, right click the skype systray icon, and chose "Options", then "Video Devices", then click the video "Test" button to check it out. You'll need to close and reopen the options window after each change.

Once you've tweaked to the best config possible, save the module settings permanently to /etc/modprobe.d/options:

Add these lines (with your values) to the "/etc/modprobe.d/options" file:
options gspca gamma=4
options gspca GRed=290
options gspca GGreen=310 sudo gedit /etc/modprobe.d/options
options gspca GBlue=315

cpysang (cpysang) said : #4

Thanks for the effort John, but sadly it did not work. There is no directory/file called /sys/module/gspca/parameters/gamma or GRed or GGreen or GBlue. there is however a directory called /sys/module/gspca_main/parameters but there are only a debug file. I also could not find the /etc/modprobe.d/options directory and file.

cpysang (cpysang) said : #6

Thanks actionparsnip, that solved my question.