Hp Pavillion webcam not working in skype

Asked by Kevin Challice on 2009-08-04

Hi guys.

Last night i chose ubuntu to replace vista on my other half's laptop. I like it lots, but i am having problems using skype, which she MUST have working as she uses it to stay in touch with all her family and freinds etc.

I have searched for hours for the solutions to my problems, and think i finally have the sound sorted, but i am still having problems with the mic and the webcam. Despite reading hundreds of orums and following links for hours to get his resolved, i have hit a brickwall.

I am a noob and will learn gradually, but i just dont know what to do right now. A step-by step guide would help, i have tried downloading and extracting r5u870_patched, but after is extracted it seems to do nothing, or at least i think so cause im used to xp/vista and dont know what to do with the extracted files.

I just want everything on the laptop to work!

Any help please?

Kevin

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Last query:
2009-08-05
Last reply:
2009-08-05
komputes (komputes) said : #1

Try getting the application cheese as it has been reported to work in there for some Pavilion owners.

As well please open a terminal and run this command:

$ lsusb

and paste the output into the next message. This will allow me to see the USB ID of the camera and see if anyone else has reported a bug against that particular hardware.

Hi there.

Thanks for replying so quickly.

I have tried cheese, that doesnt seem to make the webcam work, and the microphone is extremely sensitive, so much so it comes out very loud and distorted!

Also, in answer to your request, on input of the lsusb command, the following is displayed:

Bus 002 Device 002: ID 0461:4d22 Primax Electronics, Ltd
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 05ca:1810 Ricoh Co., Ltd

Hope this helps.

Many Thanks.

Kevin.

komputes (komputes) said : #3

Hi Kevin,

The Ricoh camera you have uses a driver/module that has licensing issues. This is currently being discussed on Bug #120434.

I suggest that you mark this bug as affecting you, subscribe to it, and leave a comment if required. There may also be workarounds available in the bug comments.

https://bugs.edge.launchpad.net/ubuntu/+bug/120434

komputes (komputes) said : #4

I also found the following Question which asks the same thing.
There are some workarounds on this page, although it is from 2007 so it may not work for Ubuntu 9.04:

https://answers.edge.launchpad.net/ubuntu/+question/18130

Hi again.

I followed the links you gave me and read through the forums, and subsequently downloaded and installed the r5u87x patch for my ricoh camera.

However, it still does not work! Should i just give up or is there any way to do this?

Many thanks.

Kevin Challice.

Tom (tom6) said : #6

Hi

This probably doesn't have any bearing on the issue at hand but have you sorted the rest of your multimedia by working through
https://help.ubuntu.com/community/Medibuntu

Do other multimedia apps seem to be working well?
Good luck and regards from
Tom :)

Can you help with this problem?

Provide an answer of your own, or ask Kevin Challice for more information if necessary.

To post a message you must log in.