how to install webcam

Asked by boogi_82 on 2009-03-17

hi, i have an a4 tech web cam and i can't make it work...
already did the "lsusb" on the terminal and here's what i got:

Bus 007 Device 011: ID 0ac8:332d Z-Star Microelectronics Corp.
Bus 007 Device 001: ID 0000:0000
Bus 006 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 04d9:1203 Holtek Semiconductor, Inc.
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

uhm... what do i do next?

please help

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Solved by:
Andre Mangan
Solved:
2009-04-12
Last query:
2009-04-12
Last reply:
2009-03-19
Andre Mangan (kyphi) said : #1

There are several hundred different webcams and the choice of which driver to use depends on the chipset used in the manufacture of the webcam. Z-Star now goes under the name of Vimicro.

The chipset in your camera is not listed. However, there is a driver available for the 321. All I can suggest is that you install the driver for that device and hope that it works.

You can download the gspcav1-20071224 driver from this address: http://mxhaard.free.fr/download.html

Installation instructions are in the Readme file.

boogi_82 (b-villafania) said : #2

reading the the installation instructions gave me a headache...

by the way i downloaded the driver and it is sitting on my desktop, was the readme file and READ_AND_INTALL the same?

i really new at this, just installed 8.04 four days ago for the first time...
the instructions looks simple enough, but could you dumb it down some more.

please?

Andre Mangan (kyphi) said : #3

Yes, the read and install file has the necessary information.

This is a very ambitious undertaking for a four-day-old.

The file comes as a zipped tarball which means that it was downloaded as a compressed (gz) bundle (tar) containing all necessary files.

It has to be unpacked and you do this via the command line interpreter (CLI). So first of all change directory to where the file is located which is your Desktop (note the capital D). Open a terminal (Applications, Accessories, Terminal and type: cd Desktop
After pressing Enter, type: tar jvf gspcav1-20071224.tar.gz
This command will unravel the tarball and you will end up with a folder on the Desktop called gspcav1-20071224.
Change directory to that folder: cd gspcav1-20071224
Then type: sudo ./gspca_build

Before you do any of the above, you would be wise to first of all make sure that your system is fully up to date and to install two items (kernel headers and build-essential) by typing:
sudo aptitude install linux-headers-$(uname -r) build-essential

Alternatively you can follow the procedure in this HowTo: https://help.ubuntu.com/community/EasyCam

If you get stuck, just ask. Good Luck.

boogi_82 (b-villafania) said : #4

i've been ungrateful so far.... thank you

i did update my system from System, Administration, Update Manager--nothing happened. i also tried it your way.
it work fine, i mean i got 9 newly installed and 7 removed, but somewhere in the middle i got this line:

Couldn't find any package whose name or description matched "linux-headers-.6.24-23-generic"
Couldn't find any package whose name or description matched "linux-headers-.6.24-23-generic"

do i need to worry?

then i went on unzipping the tarball and this showed up:

e80061@e80061-laptop:~$ cd Desktop
e80061@e80061-laptop:~/Desktop$ tar jvf gspcav1-20071224.tar.gz
tar: You must specify one of the `-Acdtrux' options
Try `tar --help' or `tar --usage' for more information.
e80061@e80061-laptop:~/Desktop$

guess i'm stuck.
so for the mean time i'm checking out link you gave

boogi_82 (b-villafania) said : #5

i think i should have made this known earlier, my internal mic is not working too.
and i thought i'd worked first with the webcam, which after some reading seems to be a bad idea 'cause it might "break" something...

hyerandy from ubuntu forums posts:

...You might be asking yourselves, why installing sound before video. I don't know why, but installing sound after the video may break nvida installation. ???? . So let's do the sound before the video...

is he right? am i on the right track here? do sound, video later.

and if that's the case, i need some more help...
just looking at their instructions might give me a nose bleed

Best Andre Mangan (kyphi) said : #6

⚕ Grasp the nose firmly between the thumb and first finger until the bleeding stops ⚕

Sorry, I forgot to include the "x" (for extract) option. The command should read: tar zxvf gspcav1-20071224.tar.gz

Both audio and video can be set by typing the command: gstreamer-properties

boogi_82 (b-villafania) said : #7

sorry it took a while to get back at you.

thank you for the solution, the web cam now works but it only works with ekiga.
i can't get it to work with amsn or by itself.