Web-cam not works

Asked by teenboy on 2012-07-05

When you start Skype, in its settings, there is mention of the camera (Genious iLook300). If you try to take a test image appears black screen and nothing is visible. The program "Cheese" camera can see.
The system - Ubuntu 12.04.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Solved by:
teenboy
Solved:
2012-07-06
Last query:
2012-07-06
Last reply:
2012-07-06

Can you give the output of:

lsb_release -a; uname -a; apt-cache policy skype; lsusb

Thanks

Skype is a mess, it causes all kinds of issues.

teenboy (teenboy) said : #2

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux teenboy-desktop 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
skype:
  Installed: 2.2.0.35-0precise3
  Candidat: 2.2.0.35-0precise3
  Ver table:
 *** 2.2.0.35-0precise3 0
        500 http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages
        100 /var/lib/dpkg/status
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 093a:2628 Pixart Imaging, Inc.
Bus 002 Device 003: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25
Bus 003 Device 002: ID 04f3:0232 Elan Microelectronics Corp.
Bus 003 Device 003: ID 0b38:0010 Gear Head 107-Key Keyboard
Bus 001 Device 007: ID 1307:0165 Transcend Information, Inc. 2GB/4GB Flash Drive

Try:

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

teenboy (teenboy) said : #4

ERROR: ld.so: object '/usr/lib32/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

ok run:

sudo updatedb; locate v4l1 | grep so

What is output?

Thanks

teenboy (teenboy) said : #6

So, preload function was useful. I found this library (v4l1compat) in other place:
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype
After this cam alive.
The last question. How can I fix this problem? Auto preload?

teenboy (teenboy) said : #7

Thanks!

You could try something like Ekiga, it's open source and has a tonne more lobe for Linux than crappy skype. The sooner it dies, the better

Rodney (rciwan) said : #9

I have release 12.04.5 LTS on my computer with all latest updates. When I try to use a web cam (using Cheese) all I get is a black screen with the possible actions all grayed out. When I do the lsusb, the web cam is recognized. I tried two different web cams which worked on older versions of Ubuntu. Now I just get black screens and greyed out choices when I open Cheese. I uninstalled and then reinstalled Cheese with the same results on the reinstall. Any suggestions as to what I am not doing or am doing wrong? One web cam was Logiteck "QuickCam Express" and the other a "Silicon Motion, Inc.".