Webcam not working Ubuntu 12.04

Asked by Daniel Parra on 2012-05-05

My cam was working and now, after installing 12.04 it's not showing anymore... here's the info I can provide

PC: HP laptop dv6000 series

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux Teressa 3.2.0-24-generic-pae #37-Ubuntu SMP Wed Apr 25 10:47:59 UTC 2012 i686 i686 i386 GNU/Linux
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 046d:c526 Logitech, Inc. Nano Receiver

Help please??

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-06
Last reply:
2013-01-28

does it work in cheese?

ARUN KUMAR P K (degreeofcold) said : #2

Try with Cheese.
"sudo apt-get install cheese"

Michael Wood (mwood) said : #3

The webcam doesn't show up in the lsusb output. Based on a google search it seems that it should show up as a USB device, (e.g. Ricoh or Microdia or Chicony are ones I've seen in the search results).

If it was working under an older version of Linux before, you could try booting off e.g. an Ubuntu 10.04 Live CD. If it works with that, you could post the lsusb output here and maybe lspci output in case the lsusb output doesn't show anything useful.

Daniel Parra (fenrir-daniel) said : #4

I already got cheese and it doesn't work either. My webcam was working in the previous version 11.10. I need to download again if I want to show you the output, please wait until I can provide you with that info, thanks for the help so far!

When you ran lsusb, did you have the device attached?

Daniel Parra (fenrir-daniel) said : #6

It's a build-in webcam, didn't work on 10.04 then upgraded to 11.10 and now it's not working again and I really wanna fix it this time, I plan on hugging 12.04 for a long time.

Daniel Parra (fenrir-daniel) said : #7

Here's the output for 11.10 ubuntu@ubuntu:~$ lsb_release -a; uname -a; lsusb
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux ubuntu 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 03f0:5307 Hewlett-Packard
Bus 004 Device 002: ID 046d:c526 Logitech, Inc. Nano Receiver

As you can see the built-in webcam is shown in the output. Cheese doesn't work in 12.04 either it says there's no device. Please help!

I have the same issue
Probably identical hardware?

hp-pavilion-dv6500-notebook-pc
    description: Notebook
    product: HP Pavilion dv6500 Notebook PC (GQ267EA#ABH)
    vendor: Hewlett-Packard
    version: Rev 1
    serial: CNF7295G82
    width: 64 bits
    capabilities: smbios-2.4 dmi-2.4 vsyscall32
    configuration: boot=oem-specific chassis=notebook family=103C_5335KV sku=GQ267EA#ABH uuid=434E4637-3239-3547-3832-001B24620676

And the same command as above:

beheerder@HP-Pavilion-dv6500-Notebook-PC:~$ lsb_release -a; uname -a; lsusb
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux HP-Pavilion-dv6500-Notebook-PC 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 046d:c03d Logitech, Inc. M-BT96a Pilot Optical Mouse
beheerder@HP-Pavilion-dv6500-Notebook-PC:~$

Rootbrian (rootbrian2000) said : #10

Same thing happening with me. Hoping for a fix real soon.

My notebook is a samsung rv 410. Ubuntu 12.04. My webcam worked with 11.04, 11.10 and 12.04. But now it doesnot work. I tested all video programs and they show device not detected.

I tested these commands:
telsouza@telsouza-RV410-RV510-S3510-E3510:~$ lsb_release
No LSB modules are available.
telsouza@telsouza-RV410-RV510-S3510-E3510:~$ uname -a
Linux telsouza-RV410-RV510-S3510-E3510 3.2.0-25-generic-pae #40-Ubuntu SMP Wed May 23 22:11:24 UTC 2012 i686 i686 i386 GNU/Linux
telsouza@telsouza-RV410-RV510-S3510-E3510:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 004: ID 1c4f:0003 SiGma Micro HID controller
Bus 006 Device 003: ID 0a5c:219c Broadcom Corp.
Bus 007 Device 002: ID 1a2c:0002
Bus 001 Device 003: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270/E870 HSDPA/HSUPA Modem

Daniel Parra (fenrir-daniel) said : #12

It seems we are not getting much done here, almost everything has been tried and nothing works. So far the only possible solution is to switch versions and I just might do that. If I go back to 11.10 I can keep my camera working.

I suggest you report a bug

On 28-05-2012 19:00, actionparsnip wrote:
> Question #196172 on cheese in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/cheese/+question/196172
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> I suggest you report a bug
>
Thanks. I do not know what is the pack or file of that error?! How to
detect it?

I have the same issue.
Probably similar hardware?

HP Pavilion dv6000 serie
    description: Notebook
    product: HP Pavilion dv6000
    vendor: Hewlett-Packard
    width: 64 bits

When I was running Ubuntu 11.10, it was working OK.
After I installed 12.04 LTS, my cam never worked again.
It doesn't work with cheese.
The installation of Ubuntu 12.04 LTS was a fresh one. I have formatted the laptop first.

I hope you already have an answer.

The output from some commands follow here:

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

lspci
00:00.0 RAM memory: NVIDIA Corporation MCP67 Memory Controller (rev a2)
00:01.0 ISA bridge: NVIDIA Corporation MCP67 ISA Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP67 SMBus (rev a2)
00:01.2 RAM memory: NVIDIA Corporation MCP67 Memory Controller (rev a2)
00:01.3 Co-processor: NVIDIA Corporation MCP67 Co-processor (rev a2)
00:02.0 USB controller: NVIDIA Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:02.1 USB controller: NVIDIA Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:04.0 USB controller: NVIDIA Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:04.1 USB controller: NVIDIA Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:06.0 IDE interface: NVIDIA Corporation MCP67 IDE Controller (rev a1)
00:07.0 Audio device: NVIDIA Corporation MCP67 High Definition Audio (rev a1)
00:08.0 PCI bridge: NVIDIA Corporation MCP67 PCI Bridge (rev a2)
00:09.0 IDE interface: NVIDIA Corporation MCP67 AHCI Controller (rev a2)
00:0a.0 Ethernet controller: NVIDIA Corporation MCP67 Ethernet (rev a2)
00:0c.0 PCI bridge: NVIDIA Corporation MCP67 PCI Express Bridge (rev a2)
00:0d.0 PCI bridge: NVIDIA Corporation MCP67 PCI Express Bridge (rev a2)
00:12.0 VGA compatible controller: NVIDIA Corporation C67 [GeForce 7150M / nForce 630M] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:05.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
02:05.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
02:05.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
02:05.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
03:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 02)

Regards.

Can you help with this problem?

Provide an answer of your own, or ask Daniel Parra for more information if necessary.

To post a message you must log in.