webcam not working

Asked by terry evans on 2011-11-26

Logiteck Qickcam deluxe has worked on earlier upgrades however it does not work on 11.10. The sound works on Skype but I am unable to download Cheese?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-26
Last reply:
2011-11-26

What is the output of:

lsb_release -a; sudo apt-get install cheese

terry evans (samtenling) said : #2

sorry but I don't understand what you mean by 'output'. I have reinstalled Cheese. It downloads on my netbook with 11.10 so I assume the problems lies with the webcam on my PC here. If the mic is working can I assume the drivers are installed? Hope this makes sense!!

Its a terminal command, copy it as one command and paste to a terminal and hit ENTER, then copy the output and paste the output here

terry evans (samtenling) said : #4

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
 sorry, hope that is OK?

Looks good, what is the output of:

sudo apt-get install cheese

terry evans (samtenling) said : #6

Reading package lists... Done
Building dependency tree
Reading state information... Done
cheese is already the newest version.
The following packages were automatically installed and are no longer required:
  tumbler tumbler-common libthunarx-2-0 xfce4-panel thunar-volman
  libgarcon-1-0 xfce-keyboard-shortcuts thunar libgarcon-common libtumbler-1-0
  libxfce4ui-1-0 thunar-data wine1.2-gecko libexo-1-0 exo-utils libexo-common
  libexo-helpers
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
terry@terry-desktop:~$
If I use apt-get-remove on the terminal I get ...E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Do you have software centre open or are updates running? If so let them finish then retry. If not then run:

sudo fuser -vki /var/lib/dpkg/lock;sudo dpkg --configure -a

And it will release the packages

terry evans (samtenling) said : #8

terry@terry-desktop:~$ sudo fuser -vki /var/lib/dpkg/lock;sudo dpkg --configure -a
[sudo] password for terry:
terry@terry-desktop:~$

I don't have software centre or updates running and when I run on terminal as instructed I get the above. How do I know if the packages have been released. When I run sudo apt-get install cheese I get the same as before?

terry evans (samtenling) said : #9

webcam works on Cheese on 11.10 on netbook.
Sound only on 11.10 on PC
Cheese pulses on launcher then dissapears.
Webcam works on Camorama on PC

Can you help with this problem?

Provide an answer of your own, or ask terry evans for more information if necessary.

To post a message you must log in.