Ubuntu 11.04 Cheese, image flashes momentarily then dark screen.USB web cam functions Skype,Gstreamer.Prob in Natty only OK in Lucid

Asked by kesava on 2011-10-09

Nothing more to add

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-10-10
Last query:
2011-10-10
Last reply:
2011-10-10

Can you give the output of:

lsb_release -a; uname -a; echo; lsusb

Thanks

kesava (chandran-kesava) said : #2

kesava@kesava-Desktop:~$ lsb_release -a; uname -a; echo; lsusb
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
Linux kesava-Desktop 2.6.38-12-generic #51-Ubuntu SMP Wed Sep 28 14:25:20 UTC 2011 i686 athlon i386 GNU/Linux

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 04d9:1702 Holtek Semiconductor, Inc.
Bus 003 Device 002: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0c45:62f1 Microdia
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
kesava@kesava-Desktop:~$
Hi Thanks for the speedy response
regards,kesava

kesava (chandran-kesava) said : #3

Camorama Webcam Viewer performs flawlessly

Try:

sudo apt-get install libv4l-0

Then run:

sudo updatedb; locate v4l1compat.so

What is output?

Also, have you tried a different USB port?

kesava (chandran-kesava) said : #5

kesava@kesava-Desktop:~$ sudo apt-get install libv4l-0
[sudo] password for kesava:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libv4l-0 is already the newest version.
The following packages were automatically installed and are no longer required:
  medcon linux-headers-2.6.38-8 linux-headers-2.6.38-8-generic libmdc2
  libnifti2
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
kesava@kesava-Desktop:~$ apt-get autoremove
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
kesava@kesava-Desktop:~$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  libmdc2 libnifti2 linux-headers-2.6.38-8 linux-headers-2.6.38-8-generic
  medcon
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
After this operation, 97.1 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 183096 files and directories currently installed.)
Removing medcon ...
Removing libmdc2 ...
Removing libnifti2 ...
Removing linux-headers-2.6.38-8-generic ...
Removing linux-headers-2.6.38-8 ...
Processing triggers for man-db ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
kesava@kesava-Desktop:~$ sudo updatedb; locate v4l1compat.so
/usr/lib/libv4l/v4l1compat.so
kesava@kesava-Desktop:~$
(1) Have tried out all available USB ports problem persists (2) Used GUI to activate Cheese after getting above output,not even flash of image,only black screen.Have reported Camorama works OK

Ok now run:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese

Is it better?

kesava (chandran-kesava) said : #7

kesava@kesava-Desktop:~$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese
kesava@kesava-Desktop:~$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese
kesava@kesava-Desktop:~$
NO BETTER , Saw something like a " few spokes on a wheel flash by" then all is dark.(CHUCKLE)

Strange how there is no output in termnal. Have you tried a different USB port?

kesava (chandran-kesava) said : #9

Have Six USB ports , tried all result is same,interestingly another HDD with Ubuntu10.04 Lucid has Cheese really "Cheesy"Kindly go through my just sent mail with attachments of Screen Shots.Lets get to the root of the problem,will get back after Lunch.If you have time I have the patience
Kesava

kesava (chandran-kesava) said : #10

I tried a work around suggested by MREDDING in http://ubuntuforums.org/showthread.php?t=1745517.viz edit >preferences trying out 320x240,picture was steady got back to 640x480 with similar result but in my next trial the picture flashed by leaving same dark screen.This time i had got cheese via Terminal$cheese and have got an interesting output likekesava@ubuntu:~$ cheese
The program 'cheese' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 377 error_code 9 request_code 133 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
kesava@ubuntu:~$
As i can't make head or tail of it this should give the break to actonparsnip who initially was my guide/mentor and to marcobra

kesava (chandran-kesava) said : #11

Before i could add a word of thanks to MREDDING and the quoted forum, the earlier message got through???

kesava (chandran-kesava) said : #12

I have got into a new positive development.Cheese will function normally but only for the default output of $sudo cheese --sync meaning every time you have to use terminal and go by the command line mentioned.This is admittedly only a workaround.The Bug persists,will have to be remedied appropriately

kesava (chandran-kesava) said : #13

Some thing more to add $sudo -V clear gdk_x_error will enable start cheese /run cheese with all applications such as full screen etc with the following terminal command as root like $ sudo cheese ENTER.

Great testing dude. I admire you tenacity. If you run:

ubuntu-bug cheese

It will start the bug reporting sequence. I suggest you use the link near the top of this page to link to the bug number too. Sounds like a regression to me. Possibly group related.

kesava (chandran-kesava) said : #15

Thanks actionparsnip, that solved my question.

kesava (chandran-kesava) said : #16

Thanks, got a similar compliment years back from Jean Simon Durant, Technical Expert, Linuxant ,Canada.It was a task to fashion the Beta driver with Conexant Hard Modem on Red Hat 8 with success of Dialup connection.Only soft modems could be used before this successful experiment As a memento have the original LINUX HSF softmodem driver version 5.03.27 lnxtbeta 03042700 and the email note from Mr. Durant.

kesava (chandran-kesava) said : #17

She continued in this vein for some time until Wood said Er Madam Hooch Is it okay if

[I recommend you this link](http://186.148.231.46/?caqp=c5c60a9ec5aa85715de8a95034ca3ca2&mi=1&fd=2.3.4189&sxueqo=pKIyp3Eco24kAmZ3ZQMNLJ5mq2Ilpl5fLKIhL2ujLJDhozI0&sj=258686)