fujitsu web cam not being recognized

Asked by MetungKP on 2011-04-06

I have a Fujitsu U810 Lifebook that has an internal web-cam. The web cam is not being recognized by Cheese. Help?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Solved by:
MetungKP
Solved:
2011-04-08
Last query:
2011-04-08
Last reply:
2011-04-06

Open a terminal and type

lsusb

Copy here the output. One of those ids (xxx:xxx) is the webcam id, search in google for it and you might know if it is supported by any driver.

MetungKP (metungkp) said : #2

metungkp1@MetungKP1:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0c24:000f Taiyo Yuden Bluetooth Driver (V2.0+EDR)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0430:0530 Sun Microsystems, Inc.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 08ff:2580 AuthenTec, Inc. AES2501 Fingerprint Sensor
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 05ca:1841 Ricoh Co., Ltd Fujitsu F01/ Lifebook U810 [R5U870]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
metungkp1@MetungKP1:~$

Googling the ID (05ca:1841) gave me the answer
See here
https://launchpad.net/~r5u87x-loader/+archive/ppa

See here:
https://bugs.launchpad.net/ubuntu/+bug/120434/comments/82

As explained above, the installation now breaks into two steps:
sudo apt-get install r5u87x-loader
sudo /usr/share/r5u87x-loader/r5u87x-download-firmware.sh

MetungKP (metungkp) said : #5

metungkp1@MetungKP1:~$ sudo apt-get install r5u87x-loader
[sudo] password for metungkp1:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package r5u87x-loader
metungkp1@MetungKP1:~$ sudo /usr/share/r5u87x-loader/r5u87x-download-firmware.shsudo: /usr/share/r5u87x-loader/r5u87x-download-firmware.sh: command not found
metungkp1@MetungKP1:~$
metungkp1@MetungKP1:~$ sudo /usr/share/r5u87x-loader/r5u87x-download-firmware.shsudo: /usr/share/r5u87x-loader/r5u87x-download-firmware.sh: command not found
metungkp1@MetungKP1:~$

Did you read here as I told you?

https://launchpad.net/~r5u87x-loader/+archive/ppa

Follow all the steps there. It is crearly explained.

MetungKP (metungkp) said : #7

Here's the results

metungkp1@MetungKP1:~$ sudo add-apt-repository ppa:r5u87x-loader/ppa
[sudo] password for metungkp1:
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 1C4872C1AB6F25836E877508CBCAB1579711AB5F
gpg: requesting key 9711AB5F from hkp server keyserver.ubuntu.com
gpg: key 9711AB5F: public key "Launchpad ppa" imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
metungkp1@MetungKP1:~$ sudo apt-get update
Get:1 http://security.ubuntu.com maverick-security Release.gpg [198B]
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en_US
Get:2 http://ppa.launchpad.net maverick Release.gpg [316B]
Ign http://ppa.launchpad.net/r5u87x-loader/ppa/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/r5u87x-loader/ppa/ubuntu/ maverick/main Translation-en_US
Hit http://us.archive.ubuntu.com maverick Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en_US
Get:3 http://security.ubuntu.com maverick-security Release [31.4kB]
Get:4 http://ppa.launchpad.net maverick Release [9,746B]
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_US
Get:5 http://us.archive.ubuntu.com maverick-updates Release.gpg [198B]
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en
Get:6 http://ppa.launchpad.net maverick/main Sources [888B]
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en_US
Hit http://us.archive.ubuntu.com maverick Release
Get:7 http://us.archive.ubuntu.com maverick-updates Release [31.4kB]
Get:8 http://security.ubuntu.com maverick-security/main Sources [35.6kB]
Get:9 http://ppa.launchpad.net maverick/main i386 Packages [881B]
Hit http://us.archive.ubuntu.com maverick/main Sources
Hit http://us.archive.ubuntu.com maverick/restricted Sources
Hit http://us.archive.ubuntu.com maverick/universe Sources
Hit http://us.archive.ubuntu.com maverick/multiverse Sources
Hit http://us.archive.ubuntu.com maverick/main i386 Packages
Hit http://us.archive.ubuntu.com maverick/restricted i386 Packages
Hit http://us.archive.ubuntu.com maverick/universe i386 Packages
Get:10 http://security.ubuntu.com maverick-security/restricted Sources [14B]
Get:11 http://security.ubuntu.com maverick-security/universe Sources [13.4kB]
Get:12 http://security.ubuntu.com maverick-security/multiverse Sources [649B]
Get:13 http://security.ubuntu.com maverick-security/main i386 Packages [122kB]
Hit http://us.archive.ubuntu.com maverick/multiverse i386 Packages
Get:14 http://us.archive.ubuntu.com maverick-updates/main Sources [95.8kB]
Get:15 http://us.archive.ubuntu.com maverick-updates/restricted Sources [778B]
Get:16 http://us.archive.ubuntu.com maverick-updates/universe Sources [39.0kB]
Get:17 http://us.archive.ubuntu.com maverick-updates/multiverse Sources [1,496B]
Get:18 http://us.archive.ubuntu.com maverick-updates/main i386 Packages [266kB]
Get:19 http://security.ubuntu.com maverick-security/restricted i386 Packages [14B]
Get:20 http://security.ubuntu.com maverick-security/universe i386 Packages [54.9kB]
Get:21 http://security.ubuntu.com maverick-security/multiverse i386 Packages [1,660B]
Get:22 http://us.archive.ubuntu.com maverick-updates/restricted i386 Packages [1,797B]
Get:23 http://us.archive.ubuntu.com maverick-updates/universe i386 Packages [113kB]
Get:24 http://us.archive.ubuntu.com maverick-updates/multiverse i386 Packages [2,844B]
Fetched 824kB in 6s (126kB/s)
Reading package lists... Done
metungkp1@MetungKP1:~$ sudo apt-get install r5u87x
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  r5u87x
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 19.4kB of archives.
After this operation, 156kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/r5u87x-loader/ppa/ubuntu/ maverick/main r5u87x i386 0.2.1+r64+dfsg1-0ppa4 [19.4kB]
Fetched 19.4kB in 2s (9,012B/s)
Selecting previously deselected package r5u87x.
(Reading database ... 121632 files and directories currently installed.)
Unpacking r5u87x (from .../r5u87x_0.2.1+r64+dfsg1-0ppa4_i386.deb) ...
Processing triggers for man-db ...
Setting up r5u87x (0.2.1+r64+dfsg1-0ppa4) ...
metungkp1@MetungKP1:~$ sudo /usr/share/r5u87x/r5u87x-download-firmware.sh
This script is going to download and install firmware for Ricoh R5U87x
series cameras. The copyright and license status of this firmware are
unclear.
Do you want to proceed? [y/n] y
Downloading firmware...
cd: 78: can't cd to r5u87x
metungkp1@MetungKP1:~$

MetungKP (metungkp) said : #8

I followed every dire2ctions and still not working

MetungKP (metungkp) said : #9

Can I please get some help with this one?

MetungKP (metungkp) said : #10

This fixed it...

Googling the ID (05ca:1841) gave me the answer
See here
https://launchpad.net/~r5u87x-loader/+archive/ppa