Webcam solution in Ubuntu 10?

Asked by Hannah Weddle on 2011-02-13

Hey All,

So I've been on forums for a whole day trying to figure this one out...seen a lot of people with the same problem and I'm wondering if any more experienced Ubuntu developers have found a workaround for this problem (The earliest I saw people mentioning this problem on forums was in Ubuntu v6).

I'm using an HP Pavilion dv2000 that I just removed Windows Vista from and installed Ubuntu v10.10
The webcam worked in the Windows Vista environment, but when trying to open Cheese or Skype, the webcam is not recognized. When checking gstreamer-preferences in the Video tab when pushing the Test button in Video for Linux (v4l), the following message appears:

Video for Linux (v4l): Device "/dev/video0" does not exist.

I checked in the 'dev' folder, and there is no 'video0' folder (like the error says). I checked kernels installed with System Profiler, and from the research that I've done I have the essential kernels for webcam and video support:

uvcvideo
Path: /lib/modules/2.6.35-25-generic/kernel/drivers/media/video/uvc/uvcvideo.ko

and

v4l1_compat
Path: /lib/modules/2.6.35-25-generic/kernels/drivers/media/video/v4l1-compat.ko

I've read in some places that the problem may be a kernel issue? I've also tried a series of commands in the Terminal to try and have the computer recognize the webcam, but it isn't being seen because it doesn't have the 'video0' folder. I've tried creating the 'video0' folder in the 'dev' folder, but it didn't work. Could it be a driver that needs to be installed for the camera?

Has anyone out there truly figured this issue out? I'm not sure it is a hardware issue because the webcam works okay in Windows Vista. Please help - this has been driving me crazy!

Thanks friends,

Hannah

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Solved by:
Hannah Weddle
Solved:
2011-02-14
Last query:
2011-02-14
Last reply:
2011-02-14
Hannah Weddle (hannahwweddle) said : #1

By the way -- upon reboot, message appears that tells me:

uvcvideo failed -5

marcus aurelius (adbiz) said : #2

it would be helpful if you gave relevant info such as which webcam you have and which version of ubuntu you're running.

Hannah Weddle (hannahwweddle) said : #3

latest v.10.10 32-bit of Ubuntu

My specs from the manufacturer documentation just says HP Webcam. I think it is MSI manfactured from reading about other versions of this laptop in other forums, but it is built into the screen.

Hannah Weddle (hannahwweddle) said : #4

when running lsusb
in Terminal

Bus 001 Device 003: ID05ca:1810 Ricoh Co., Ltd Pavilion Webcam [R5U870]

if that helps too -- thanks marcus!

Hannah Weddle (hannahwweddle) said : #5

found this link, but I'm not sure what to download (from link on the right) or how to manually build/install the driver...I'm just new to linux -- love it, but still learning!

http://www.arakhne.org/ricoh/index.html