Why does Cheese not find my EasyCap /dev/video0?

Asked by grahame pratt on 2011-01-20

I have the latest Cheese on an up-to-date Ubuntu Lucid box. I can see the frames in EasyCap (USB C60) in VLC Media Player, but I need to save an image every 30 seconds. Cheese just gives me nothing but the default graphic. Can you help me make this work, or alternatively suggest a different video capture device. Thanks --Grahame ( P.S. I'm very ignorant about Linux, only a few installations seem to work for me).

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu cheese Edit question
Assignee:
No assignee Edit question
Last query:
2011-01-22
Last reply:
2011-01-22
Ubfan (ubfan1) said : #1

Try luvcview instead of cheese.
I have a webcam which cheese cannot find, but luvcview and skype find OK.

Mike Thomas (rmthomas) said : #2

Hi Grahame,

You could try varying the "Default Input" fields in the "Video" tab which appears when you run the command

gstreamer-properties

within a terminal window. (I think the gstreamer-properties utility is in the package gnome-media, which may be automatically installed in Lucid.) For an EasyCAP the settings "Video 4 Linux 2" and "Custom" are the relevant ones - not "Video 4 Linux". The meaning of the various settings is a mystery to me, but I find that after some random changes I can sometimes get Cheese to find the video input. Then I forget what I did, and need to proceed randomly again next time :-)

Mike

marcus aurelius (adbiz) said : #3

you might want to get the latest updates to see if that will get your webcam recognized. i have 3 older ones that weren't recognized before, 1 of them is now.

grahame pratt (softappstudio) said : #4

Thanks everybody for the suggestions.

So I followed up on gstreamer-properties: this is definitely not happy, so I need to fix it. It shows the EasyCap C60 as the default video divice, but locks up permanently during/after "checking pipeline, or somesuch" - I can only reboot to clear it. As gstreamer runs it announces ...

grahame@C-2-Q-Ubuntu:~$ gstreamer-properties
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'

Which looks fairly awful.
All suggestions very welcome.
--G

grahame pratt (softappstudio) said : #5

I have not done well enough with luvcview .....

grahame@C-2-Q-Ubuntu:~$ luvcview -fYUVY -S
luvcview 0.2.6

SDL information:
  Video driver: x11
  A window manager is available
Device information:
  Device path: /dev/video0
Stream settings:
  Frame format: UYVY (MJPG is not supported by device)
  Frame size: 640x480
Unable to set frame rate: Invalid argument
 Init v4L2 failed !! exit fatal

I ran "man luvcview" but could not see how to set the missing framerate. Should I continue with this or address the gstreamer-... problem first?
Thanks for any input.
--G

grahame pratt (softappstudio) said : #6

OK, so I figured out how to kill "gstreamer-properties" when it locks up verifying the input stream, I do ..

{System}{Administration}{Sytem Monitor} then select the process and do {Kill}.

So, now "how to fix it?"
--G

Ubfan (ubfan1) said : #7

luvcview -L
should show the valid frame rates for each resolution of the camera.
You can specify a frame rate with -i rate , but if the device does not support that rate, it will be rejected.
Try just lucview without args first, it should default to something which works.

grahame pratt (softappstudio) said : #8

Thanks Ubfan, but I still do not seem to "be there".

lvcview -L indicates that a valid configuration -- among many for one device-- is 640x480 @ 1/25,1/5 frame interval (why the two values?).

I have tried issuing
luvcview -i 25
luvcview -i 5
luvcview -i25
luvcview -i5

And they all result in "Invalid argument". I never get to see anything.
I have done this with three different USB video capture devices, all of which work under Win XP, and all of which are recognized by lsusb. Yet I cannot capture any of the streams with cheese, and VLC Media Player is so erratic in finding /dev/video0 that it is unusable.

There seems to me to be a *major problem* with these video capture programs. I am strongly motivated to get something to work because I need to provide my sleep and pulmonary specialist physicians with records of what happens when I am asleep (I cannot spend every night in a sleep lab!). So any concerted effort by the "Ubuntu wizards" will definitely be appreciated by yours truly.

When I issue ...
root@C-2-Q-Ubuntu:/home/grahame/Downloads/cheese-2.91.3# gstreamer-properties
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'

I get pages of error messages, I think mostly about missing plugins -- I bet there are over 20 of them -- and a general message similar to ....

(gstreamer-properties:6880): gstreamer-properties-WARNING **: gst_properties_gconf_set_string() error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

When I run gstreamer-properties I get the MultiMedia Systems Selector, and on the [Video] tab I can select any of the options for "Default Output" {Plugin},{Device},{Pipeline} and I get the same result when I click [Test]: the bottom right corner of the pop-up shows B/W snow, although a good video feed is coming down the line.

Under "Default Input" I can select v4l2 as the plugin, and this lets me select the correct USB Device ( e.g. EasyCAP DC60). The greyed-out pipeline is "v4l2src device="/dev/video0". When I click [Test] I get the error message "Video for Linux 2 (v4l2): no element :null"

I have to readily confess that I do not have a clue what is not working properly.

Please let me have any further thoughts you have.

--Grahame

Mike Thomas (rmthomas) said : #9

Hi Grahame,

Sorry to hear that you're still having trouble with this. A few minutes ago I tested version 0.9 of the easycapdc60 driver from SourceForge on Ubuntu 10.10 (I don't have Ubuntu 10.04 LTS on any mechines here at the moment) and everything seems okay. I ran gstreamer-properties and got some messages about missing plugins, ignored these and set up the controls in the little window like this:

AUDIO TAB:
  Default Output: Plugin: ALSA; Device: default; Pipeline: greyed
  Default Input: Plugin: ALSA; Device: EasyALSA0; Pipeline: greyed
  Clicking on the lower Test button gave good audio output.
VIDEO TAB:
  Default Output: Plugin: Autodetect; Device: greyed; Pipeline: greyed
  Default Input: Plugin: Custom; Device: greyed; Pipeline: v4l2src device="/dev/video0"
  Clicking on lower Test button gave good video output.

I closed gstreamer-properties and started Cheese from the menu:

Applications->Sound & Video->Cheese Webcam Booth

and immediately got good video. I am using an NTSC videotape as an analogue audio-video signal source for these tests.

I had a look at the file README.TESTMATRIX which is in the driver's installation directory and noted that the version of Cheese included in Ubuntu 10.04 (Lucid) gives a poor picture (unusable actually) with the EasyCAP DC60, whereas the version of Cheese in Ubuntu 10.10 works well. So if you intend to pursue this, you'll probably need to upgrade to 10.10 (Maverick) or 11.04 (Natty) at some stage. But this does not explain why you are seeing nothing at all from Cheese on Ubuntu 10.04 - there really ought to be some visible output.

We need to figure out how your setup differs from mine in a way which prevents yours working. It's not clear to me at the moment what that might be.

I don't get any of your messages from gstreamer-properties involving "Failed to contact configuration server" and I've no idea what this is about. Also, on my system gstreamer complains about only nine missing plugins, not twenty. I don't know what is going on here either.

I installed luvcview, but found it does not work with the EasyCAP DC60 because the EasyCAP does not use the (widespread) UVC webcam protocol.

Not sure that this helps much.

Mike

Can you help with this problem?

Provide an answer of your own, or ask grahame pratt for more information if necessary.

To post a message you must log in.