pkg_resources.VersionConflict: when installing Ceilometer

Asked by Mulz on 2013-08-27

Hi All,

I am installing Ceilometer on a ubuntu 12.04 server. for tracking Swift objects and containers and have already hit a roadblock. I have religiously followed the instruction as per the following link:

http://docs.openstack.org/developer/ceilometer/install/manual.html#installing-manually

When I tried executing the step 5 i.e.

$ git clone https://git.openstack.org/openstack/ceilometer.git

I get the following error:

# python setup.py install
Traceback (most recent call last):
  File "setup.py", line 22, in <module>
    pbr=True)
  File "/usr/lib/python2.7/distutils/core.py", line 112, in setup
    _setup_distribution = dist = klass(attrs)
  File "/usr/local/lib/python2.7/dist-packages/setuptools/dist.py", line 221, in __init__
    self.fetch_build_eggs(attrs.pop('setup_requires'))
  File "/usr/local/lib/python2.7/dist-packages/setuptools/dist.py", line 245, in fetch_build_eggs
    parse_requirements(requires), installer=self.fetch_build_egg
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources.py", line 598, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (pbr 0.5.18 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.5.21,<1.0'))

Has anyone seen the error? What's the remedy?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ceilometer Edit question
Assignee:
No assignee Edit question
Solved by:
Mulz
Solved:
2013-08-27
Last query:
2013-08-27
Last reply:
Mulz (ormulz) said : #1

Fixed it myself. The version of the pbr was 0.5.18 and hence an upgrade fixed the problem (i.e. pip install --upgrade pbr).