What is required for casper X generation hooks to work?

Asked by Mario Limonciello on 2007-06-24

I'm working on a live disk from scratch for Mythbuntu(as in building from a debootstrap up). (I've already seen reconstructor, but it doesn't fit our needs).

The disk is fully functional except that casper seems to be skipping something important. Every time the disk is booted, the xorg.conf that is generated uses the 'vesa' driver. Even if the card is supported by 'ati' or 'nv', vesa still gets chosen. So my question then is what could casper be missing to properly do video card detection?

The CD is launched like this for us atm:
LABEL live
  menu label ^Start or install Mythbuntu
  kernel /casper/vmlinuz
  append file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash --

The casper hooks appear to generally work, because X does get configured, and gdm is set to automatically log in to the ubuntu user for us.

Is there a config option somewhere to actually enable the video card detection then? Or a debconf option that needs to be set?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu casper Edit question
Assignee:
No assignee Edit question
Solved by:
Mario Limonciello
Solved:
2007-06-24
Last query:
2007-06-24
Last reply:
Mario Limonciello (superm1) said : #1

By adding break=bottom to the live CD menu, I was able to see casper.log during the boot process. It appears that the autodiscovery module 'discover' isn't installed (or a dependency of casper for that matter). It's provided by both the package 'discover' and the package 'discover1'. I'll have to experiment and see which one provides better results.

Best Mario Limonciello (superm1) said : #2

Indeed the problem is caused by discover1 not being installed. I attached a patch to bug 122040 for this.