installed calligra 3.0.1 but cannot find calligra stage

Asked by Ed Silkworth on 2019-01-30

Hi.

I am trying to install Calligra Stage 3.0.1 in Kubuntu 18.04 LTS.

I installed Calligra 3.0.1 using KDE's Discover.
Calliga Words and Sheets appear in the application launcher, but Stage does not.

I also tried sudo apt install calligrastage, but it made no difference.
In addition, I tried running calligrastage from Konsole, but the terminal states: "calligrastage: command not found."

I imagine that if I install Calligra or Calligra Stage directly, then Stage should appear in the application launcher and be executable from the command line.

Did I do anything wrong?
Or, is the calligrastage package incomplete?

I would like to stick with the LTS release and am hoping to use Calligra Stage 3.0.1, unless perhaps the package can be completed or Calligra Stage 3.1.0 can be backported (if that's the correct term).

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu calligra Edit question
Assignee:
No assignee Edit question
Solved by:
Ed Silkworth
Solved:
2019-02-01
Last query:
2019-02-01
Last reply:
2019-01-31
Manfred Hampl (m-hampl) said : #1

I suggest that you create a bug report.

Ed Silkworth (saegl5) said : #2

okay, thank you, will do so

Ed Silkworth (saegl5) said : #3

Turns out that Stage is not included because it had no maintainer.

I compiled Calligra 3.0.1 from source, and CMAKE output:
"The following required product(set)s/features can NOT be built
APP_STAGE: Stage app (for Desktop) [[needed by: STAGE]] | No maintainer currently"

Ed Silkworth (saegl5) said : #4

So, I'll mark this as solved.

Ed Silkworth (saegl5) said : #5

In case anyone wonders, though...

One CAN compile Calligra 3.0.1 from source WITH Stage included.
Append "-DBUILD_UNMAINTAINED=TRUE" to the CMAKE command.
Same applies to Calligra 3.1.0 (from source code).

For now, obtaining Stage is easiest by upgrading to Kubuntu 18.10 and installing it through Discover (or Ubuntu 18.10 Software Center, I presume).
But, again, I personally would like to stick with the LTS release.