Failed to set data: Could not set data

Asked by Caroline K. on 2013-02-26

Hey there! I upgraded to ver. 0.9.20 today and opened up Calibre. When I tried to edit meta data for the books, I got the error message below saying "ERROR: Failed to set data: Could not set data" and the database is locked.

Also, I can't import any books or use any of the library features like "create/switch library", "remove library" etc.

I can however open up a book within Calibre.

Thanks for any help.


calibre, version 0.9.20
ERROR: Failed to set data: Could not set data, click Show Details to see why.

Traceback (most recent call last):
  File "site-packages/calibre/gui2/library/", line 980, in setData
  File "site-packages/calibre/gui2/library/", line 1054, in _set_data
  File "site-packages/calibre/library/", line 2193, in set
  File "site-packages/calibre/library/", line 2530, in set_title
  File "site-packages/calibre/library/", line 633, in set_path
  File "site-packages/calibre/library/", line 1504, in add_format
  File "site-packages/calibre/library/", line 314, in run
DatabaseException: database is locked
 RemoteTraceback (most recent call last):
   File "site-packages/calibre/library/", line 271, in run
 OperationalError: database is locked

Question information

English Edit question
Ubuntu calibre Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

I suggest you report a bug

Revision history for this message
Caroline K. (kanyiva) said :

Thanks actionparsnip, that solved my question.