calibre doesn't open after upgrading to natty

Asked by S.Rey on 2011-04-25

I upgraded my maverick to natty beta and calibre stopped working.
Here is the traceback when trying to open it from a console:
-----------------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/bin/calibre", line 18, in <module>
    from calibre.gui2.main import main
  File "/usr/lib/calibre/calibre/gui2/main.py", line 19, in <module>
    from calibre.library.database2 import LibraryDatabase2
  File "/usr/lib/calibre/calibre/library/database2.py", line 22, in <module>
    from calibre.library.caches import ResultCache
  File "/usr/lib/calibre/calibre/library/caches.py", line 16, in <module>
    from calibre.utils.search_query_parser import SearchQueryParser
  File "/usr/lib/calibre/calibre/utils/search_query_parser.py", line 21, in <module>
    from pyparsing import CaselessKeyword, Group, Forward, \
ImportError: Bad magic number in /usr/lib/calibre/calibre/utils/pyparsing.pyc
----------------------------------------------------------------------------
My system is fully updated, with only the official repositories.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu calibre Edit question
Assignee:
No assignee Edit question
Solved by:
S.Rey
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Log a bug. natty is NOT ready and NOT stable so you will get issues

Revision history for this message
S.Rey (s.rey) said :
#2

Problem solved after a fresh install of natty. (Something went bat with the upgrade from maverick).