unable to install libcairo2:i386 on 12.10 x86_64

Asked by odror on 2012-11-15

When installing it I get the following message:

# apt-get install libcairo2:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libatk-wrapper-java-jni : Depends: libgtk2.0-0 (>= 2.12.0) but it is not going to be installed
                           Depends: libatk-wrapper-java (>= 0.30.4-0ubuntu4) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I suspect that it fails because the 32bit version is different from the 64 bit version. Because of this incompatibility I am not able to install seam on my Ubuntu 12.10 (64 bit). I have similar issue when trying to install wine.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cairo Edit question
Assignee:
No assignee Edit question
Solved by:
odror
Solved:
2012-11-20
Last query:
2012-11-20
Last reply:
2012-11-19
Micah Gersten (micahg) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug. There is also a vibrant support community available at http://askubuntu.com and you might consider asking your question there.

for what it's worth, I was able to install this package in a clean chroot. I also had it installed on my quantal amd64 system.

odror (ozdror) said : #2

I would like to add that If I install it manually with dpkg I get the following error:

# dpkg -i libcairo2_1.12.2-1ubuntu2_i386.deb
Selecting previously unselected package libcairo2:i386.
(Reading database ... 457106 files and directories currently installed.)
Unpacking libcairo2:i386 (from libcairo2_1.12.2-1ubuntu2_i386.deb) ...
De-configuring libcairo2:amd64 ...
dpkg: error processing libcairo2:i386 (--install):
 package libcairo2:i386 1.12.2-1ubuntu2 cannot be configured because libcairo2:amd64 is at a different version (1.12.3+git20120608.f228769d-0ubuntu0ricotz~quantal0)
dpkg: error processing libcairo2:amd64 (--install):
 package libcairo2:amd64 1.12.3+git20120608.f228769d-0ubuntu0ricotz~quantal0 cannot be configured because libcairo2:i386 is at a different version (1.12.2-1ubuntu2)
Errors were encountered while processing:
 libcairo2:i386
 libcairo2:amd64

You have added this PPA:
https://launchpad.net/~ricotz/+archive/testing

Which is why you are getting the issues. I suggest you remove the PPA using ppa-purge and retry. If you add 3rd party sources for packages then get issues, don't be surprised. Especially something as critical as your desktop environment.

The PPA even says:

Make sure you know what you are doing! You are getting bleeding edge snapshots!
You should have a stable experience most of the time, but there will be problems!

So why add it!!?? What do you need the PPA for?

odror (ozdror) said : #4

Actually this PPA has been checked off. it is not supposed to be a problem. I do not remember why I used it to begin with. Possibly to enhance unity. How can I fix the problem caused by this PPA. Thanks

sudo apt-get install ppa-purge
ppa-purge ppa:ricotz/testing

odror (ozdror) said : #6

I purged the package as you suggested. Then I did apt-get update. I have the same issue of not being able to install libcairo2:i386.

Manfred Hampl (m-hampl) said : #7

Try

apt-get --simulate install --reinstall libcairo2=1.12.2-1ubuntu2 libcairo2:i386=1.12.2-1ubuntu2

and copy/paste all output.

odror (ozdror) said : #8

apt-get --simulate install --reinstall libcairo2=1.12.2-1ubuntu2 libcairo2:i386=1.12.2-1ubuntu2

# apt-get --simulate install --reinstall libcairo2=1.12.2-1ubuntu2 libcairo2:i386=1.12.2-1ubuntu2
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  browser-plugin-gnash cheese cheese-common ekiga fonts-cantarell gdebi
  glchess glines gnash gnash-common gnect gnibbles gnobots2 gnome-backgrounds
  gnome-dictionary gnome-games gnome-icon-theme-extras gnome-js-common
  gnome-search-tool gnome-video-effects gnotravex gnotski gnuchess
  gnuchess-book gstreamer1.0-plugins-bad gtali hamster-applet
  hamster-indicator iagno inkscape kopete kopete-message-indicator lib32gcc1
  libc6-i386 libcapi20-3 libcheese-gtk23 libcheese7 libclutter-gst-2.0-0
  libgadu3 libgc1c2 libgdict-1.0-6 libgdict-common libgsoap2
  libgstreamer-plugins-bad1.0-0 libkopete4 libmediastreamer1 libmpg123-0
  libmsn0.3 libmyth-0.25-0 libodbc1 libopal3.10.4 libortp8 libotr2 libpt2.10.4
  libseed-gtk3-0 libsrtp0 libunique-1.0-0 liferea liferea-data lightsoff
  menu-xdg mythbrowser mythnetvision mythnews plasma-containments-addons
  plasma-runners-addons python-cheetah python-flup python-uniconvertor
  python-webpy python-wnck python-xappy quadrapassel sound-juicer sweeper
  swell-foop ttf-sil-gentium-basic
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  libcairo2:i386
The following packages will be DOWNGRADED:
  libcairo2
0 upgraded, 1 newly installed, 1 downgraded, 0 to remove and 34 not upgraded.
Inst libcairo2 [1.12.3+git20120608.f228769d-0ubuntu0ricotz~quantal0] (1.12.2-1ubuntu2 Ubuntu:12.10/quantal [amd64])
Inst libcairo2:i386 (1.12.2-1ubuntu2 Ubuntu:12.10/quantal [i386])
Conf libcairo2 (1.12.2-1ubuntu2 Ubuntu:12.10/quantal [amd64])
Conf libcairo2:i386 (1.12.2-1ubuntu2 Ubuntu:12.10/quantal [i386])

Manfred Hampl (m-hampl) said : #9

The simulation of that command seems successful, now really execute the command by issuing

sudo apt-get install --reinstall libcairo2=1.12.2-1ubuntu2 libcairo2:i386=1.12.2-1ubuntu2

odror (ozdror) said : #10

I have solved the problem. Many of my packages were "contaminated" by the ricotz ppa. I had to download manually each of these packages and install using dpkg -i. When this was done I was ale to install steam and wine.