autostart program in cairo-dock

Asked by Larry Jordan on 2012-10-11

     Hi. Recently rebuilt Ubuntu, now using version 11.10, and have some issues. Main one is that I have a homegrown program I use, written mostly in Bash, that I used to be able to autostart. I used to just have the name (sometimes including path) in either a .bash_profile or .bash_login file and it worked fine. The more Linux moves to newer versions, the more difficult it seems to be to get it to work. I've looked at options on line that say put the program name into something like .config/autostart or .kde/Autostart, but these aren't optimal for me and don't work anyway. I don't want to put it into an init.d setting, because the program starts running too early. I need to be logged in first at least, and want everything else settled in - up and running. If I could get it working using just gnome or just kde, I might be willing to give up on cairo-dock, since it's just eye candy, but I would rather have it working regardless of desktop.
    So how do I fix this? Any ideas appreciated...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cairo-dock Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-10-11
Last query:
2012-10-11
Last reply:
2012-10-11
Best N1ck 7h0m4d4k15 (nicktux) said : #1

On 10/11/2012 02:41 PM, Larry Jordan wrote:
> New question #210930 on Ubuntu:
> https://answers.launchpad.net/ubuntu/+question/210930
>
> Hi. Recently rebuilt Ubuntu, now using version 11.10, and have some issues. Main one is that I have a homegrown program I use, written mostly in Bash, that I used to be able to autostart. I used to just have the name (sometimes including path) in either a .bash_profile or .bash_login file and it worked fine. The more Linux moves to newer versions, the more difficult it seems to be to get it to work. I've looked at options on line that say put the program name into something like .config/autostart or .kde/Autostart, but these aren't optimal for me and don't work anyway. I don't want to put it into an init.d setting, because the program starts running too early. I need to be logged in first at least, and want everything else settled in - up and running. If I could get it working using just gnome or just kde, I might be willing to give up on cairo-dock, since it's just eye candy, but I would rather have it working regardless of desktop.
> So how do I fix this? Any ideas appreciated...
>
Hi ,
you can add an autostart .desktop entry in /etc/xdg/autostart/

connect there and read some examples from other already autostart programs.

cd /etc/xdg/autostart

ls

open a .desktop file and read it

example

cat nm-applet.desktop

If its a bash script the only thing you must do is to add it to startup
applications

at the command box , write the full path of the script.

Thanks

Larry Jordan (larryjor) said : #2

    Thanks; the startup applications seems to have done the trick for me. Will look into autostart programs later, because I'm working on converting it completely to a C program as time allows. For now, you have solved my problem.

Larry Jordan (larryjor) said : #3

Thanks NikTh, that solved my question.