Impossible to use bzr

Asked by Fabio Marconi on 2010-11-14

Binary package hint: bzr

I'm trying to download but everytime i've got errors.
njin@Lucid:~$ bzr branch lp:a4
Permission denied (publickey).
bzr: ERROR: Connection closed: Unexpected end of message. Please check connectivity and permissions, and report a bug if problems persist.
or by root
njin@Lucid:~$ sudo bzr branch lp:a4
[sudo] password for njin:
The authenticity of host 'bazaar.launchpad.net (91.189.90.11)' can't be established.
RSA key fingerprint is 9d:38:3a:63:b1:d5:6f:c4:44:67:53:49:2e:ee:fc:89.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'bazaar.launchpad.net,91.189.90.11' (RSA) to the list of known hosts.
Permission denied (publickey).

The key is up on launchpad, but i can't understand why i've gotr these errors.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: bzr 2.2.1-0ubuntu1
Uname: Linux 2.6.37-020637rc1-generic x86_64
Architecture: amd64
CheckboxSubmission: da0a9053457cd51534683f0d3b1afbb3
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
Date: Sun Nov 14 17:59:51 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
SourcePackage: bzr

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bzr Edit question
Assignee:
No assignee Edit question
Solved by:
Fabio Marconi
Solved:
2010-11-14
Last query:
2010-11-14
Last reply:
2010-11-14

This question was originally filed as bug #675233.

Fabio Marconi (fabiomarconi) said : #1
Martin Packman (gz) said : #2

This is a problem with your ssh configuration. Note the "Permission denied (publickey)." which means you don't have the key you've got registered on launchpad on that user account. Compare the contents of ~/.ssh/id_rsa.pub with <https://launchpad.net/~fabiomarconi/+sshkeys> and check that the corresponding private key ~/.ssh/id_rsa is only readable by your user.

Fabio Marconi (fabiomarconi) said : #3

I don't have it in ~/.ssh

Fabio Marconi (fabiomarconi) said : #4

OK, Thanks i've recreated the key, it was missed.
Fabio

Fabio Marconi (fabiomarconi) said : #5

solved

meegotest (meego-test5) said : #6

where can find the ~/.ssh/id_rsa.pub? I have the same issue when tried to use bzr branch,

Jelmer Vernooij (jelmer) said : #7

~/.ssh/id_rsa.pub can be generated by the ssh-keygen utility. See http://wiki.bazaar.canonical.com/Bzr_and_SSH