error on starting byobu

Asked by Jori Gel on 2016-09-01

what to do about an error showing up when starting byobu on a precise-server saying:

/usr/bin/byobu: 50: .: Can't open //lib/byobu/include/common

instead of starting the program. There is no byobu-dir in /lib neither on a server where it works out perfectly nor on this one. A reinstall of byobu doesn't help either. Can't think of what's going wrong here.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu byobu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2016-09-02
Last query:
2016-09-02
Last reply:
2016-09-01
Best Manfred Hampl (m-hampl) said : #1

lines 48 to 50 in /usr/bin/byobu are

[ -r "$HOME/.byoburc" ] && . "$HOME/.byoburc"
[ -z "${BYOBU_PREFIX}" ] && export BYOBU_PREFIX="/usr" || export BYOBU_PREFIX
. "${BYOBU_PREFIX}/lib/${PKG}/include/common"

There seems to be something wrong with the definition of BYOBU_PREFIX on your system.

Is there a file $HOME/.byoburc and if yes, what are its contents?

Jori Gel (jorigel) said : #2

I did not expect the system to generate this configuration-file by itself (two slashes as a path definition). So I deleted the file from home and voila it worked again. ThanX for that advice.

Jori Gel (jorigel) said : #3

Thanks Manfred Hampl, that solved my question.