Create new windows does not maintain pwd

Asked by Biocyberman on 2016-04-10

Hello byobu developers. I posted the question on askubuntu.com, but decided to bring it here.

I recently removed `tmux 1.8` from Ubuntu 14.04, and compiled `tmux 2.2` and installed it via `make install`. I need the newer tmux version for its true terminal color support. All other things seem to work fine, only hitting `F2`, `Ctrl + F2` or `Shift + F2` does not maintain the same present working directory. They all fall back to `~` (home dir). This is not what I want because I usually open new window or new split to do the things related to the directory at current window.

    byobu -v
    byobu version 5.74
    tmux 2.2

How do I fix this? I guess (very general) the problem is that byobu 5.74 does not know about the changes in tmux 2.2

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu byobu Edit question
Assignee:
No assignee Edit question
Solved by:
Biocyberman
Solved:
2016-04-11
Last query:
2016-04-11
Last reply:
2016-04-11

I suggest you report a bug.

Biocyberman (biocyberman) said : #2

I download the latest byobu .deb file for Xenial and install it on Trusty. That's is an unrecommended route in most of the case. But since byobu does not seem picky about dependencies. I installed with `sudo gdebi ...deb` without a problem.

Now I have

byobu --version
byobu version 5.105
tmux 2.2

These two work fine, I get correct PWD again :) Apparently this problem has been addressed

So problem solved.

Biocyberman (biocyberman) said : #3

For someone in the same situation: After installation, make sure to kill all old tmux sessions AFTER you have saved all your work by running `sudo killall tmux`.