byobu unusable because of special characters

Asked by Shum on 2012-07-18

On Ubuntu, byobu's status line contains special unicode characters that are displayed as multiple characters by non-ubuntu terminals. This means that when I log into my ubuntu machine from a non-ubuntu machine and try to use byobu the status line overflows the bottom line of the terminal (see: http://imgur.com/WCCRk). Naturally, I don't want to have to use Ubuntu's special font with all it's branding as my terminal font on every machine that I want to log into my ubuntu box with. So can I change this somehow? Is there a way to tell byobu to only use characters on it's status line that other machines can reasonably be expected to be able to display?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu byobu Edit question
Assignee:
No assignee Edit question
Last query:
2012-07-18
Last reply:
2012-08-19
Shum (himthingwatsit) said : #1

Would it be possible for byobu to detect what characters the terminal can display when it loads up? That way it'll only show the ubuntu logo and whatnot when I'm physically on the ubuntu machine? Does it try to do this already but my terminal settings are confusing it somehow?

By the way, I'm sshing in from a Gentoo box and tried using both xfce-terminal and sakura.

Jeet (gour-jitendrasingh) said : #2

have you tried changed encoding to UTF-8, it may be helpful

Edward Ost (edward-ost) said : #3

The screenshot seems to indicate that the problem is that you byobu is running tmux rather than screen as the back end. You can change that by running byobu-select-backend command, or by launching byobu with screen explicitly using the byobu-screen command.

I still get some ugly characters on my screen, and perhaps it is UTF-8 related. but for the most par tit works.

Edward Ost (edward-ost) said : #4

after you fix the scrolling phenomenon, you can fix the funny characters by selecting utf-8 for your ssh client translation. For putty (windows) you can find that in the menu under Configuration -> Window -> Translation -> UTF-8 .

Not sure how to set translation on a linux ssh client. Of course, you could change your own locale. But assuming there is a good reason not to, you might try the -t flag in a linux ssh client. I'm not really sure how to set it completely, but you might try

ssh -t user@192.168.0.101 'LANG=en_CA.utf8 exec tmux att -d'

Can you help with this problem?

Provide an answer of your own, or ask Shum for more information if necessary.

To post a message you must log in.