No terminal scroll bar

Asked by James McKelvey on 2011-11-27

I recently upgraded to 11.10. The terminal (Byobu) is set up with scroll back, but the scroll bars do not appear. It doesn't matter if I set them on left or right, or unlimited. They were there in 10.10. It's the same in Unity and Gnome.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu byobu Edit question
Assignee:
No assignee Edit question
Solved by:
James McKelvey
Solved:
2011-11-30
Last query:
2011-11-30
Last reply:
2011-11-28
marcus aurelius (adbiz) said : #1

under 11.10, the scrollbars look different. their a sliver instead of the thick bars you see in previous version. list try scrolling on the far right edge of very bottom edge of your touchpad. if it scrolls, the scrollbars are there. by default, the scrollbars look red.

James McKelvey (mckelvey) said : #2

I don't see any, even skinny ones. I can't see any red, either.

Ubfan (ubfan1) said : #3

In the gnome-terminal, the scrollbar red indicator is truly invisible, but you should see something on the right when you really have enough text to scroll. If you want to simply get rid of the new scroll bars, and revert back to the old ones, remove the three packages with overlay scrollbar in their names.

James McKelvey (mckelvey) said : #4

OK, I got rid of the new scrollbars. Now I have fat scrollbars. But it always shows 100%, no matter how many lines there are.
In other words, I still cannot scroll back.

The problem must be something more basic.

Ubfan (ubfan1) said : #5

Oops previously missed "left" scrollbar red indicator....
Take a look at the xterm scrollbars, do they work? Take a look at the gnome-terminal edit/profiles... menu item, edit the profile you are using, and see how many scroll lines you have selected. The default is 512 lines. I suppose it could be 1, and suppress scrolling.

James McKelvey (mckelvey) said : #6

It's set to 512. Setting it to unlimited makes no difference.

I tried an xterm. No scroll bars at all. terminal or gnome-terminal is just byobu.

Here's another odd thing. If I launch a gnome-terminal, xterm, or another Byobu, they are all linked, in the sense that what is typed in one appears in all others.

Something is very wrong.

Ubfan (ubfan1) said : #7

You have to explicitly request scroll bars for an xterm with the -sb switch
xterm -sb
List something big like /usr/bin, and the scroll bar should be a small black button at the bottom of the scroll track.
Never ran byobu before, but all terminals running it get the same output on my 10.04 system too.

James McKelvey (mckelvey) said : #8

OK, got scroll bars on xterm, but they are always at 100%.

When I run terminal, it says byobu on the title bar. There doesn't seem to be any other terminal emulator. Even xterm says byobu at the top.

The only difference is xterm uses a smaller font and has a black background. The data is still linked.

I don't remember the data being linked in 10, but that wasn't byobu. The data has never been linked on any other Linux system I have used.

Ubfan (ubfan1) said : #9

The xterm scroll bar moves up on right button clicks, down on left clicks, and you drag it with a middle button hold.
It's not visually much more than a different color bar in the track.about one line high on my default settings.
There is something odd with the xterm invocation under 11.10, the explicit command xterm -e byobu under 10.04 runs the byobu command in the xterminal, but does not even have the xterm show up under 11.10. Check your aliases for xterm, run it explicitly with /usr/bin/xterm -sb to get rid of byobu.

James McKelvey (mckelvey) said : #10

Everything in /usr/bin/*term* comes up as byobo, and the contents are still linked and the scrollbars are at 100% no matter how many lines there are.

James McKelvey (mckelvey) said : #11

I found the solution.

byobu-disable

gets rid of the awful thing. Scrollbars work properly, you can bring up multiple terminals without linking. Back to normal.

Thanks for your help.