F6 key press is quite confusing

Asked by Brian Murray on 2010-06-02

Binary package hint: byobu

In alsamixer F6 is for switching soundcards so I was quite confused to have byobu quit on me. I think alsamixer is something a user of byobu would likely use so maybe F6 shouldn't have a keybinding.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: byobu 2.68-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
CheckboxSubmission: fee5e196cb921cbd36888f428b38b488
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Wed Jun 2 10:12:54 2010
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: byobu

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu byobu Edit question
Assignee:
No assignee Edit question
Solved by:
Dustin Kirkland 
Solved:
2010-06-03
Last query:
2010-06-03
Last reply:
2010-06-03

This question was originally filed as bug #588838.

Brian Murray (brian-murray) said : #1
Dustin Kirkland  (kirkland) said : #2

Hey Brian-

That's a tough one ...

We tried to bind all of the F-keys in Byobu that weren't already taken in gnome-terminal and konsole. This basically excluded byobu from using:

# F1 | 'help' in gnome-terminal
# F10 | 'toolbar' in gnome-terminal
# F11 | 'fullscreen' in gnome-terminal

However, I respect your question, and these comes up from time to time. Two programs which are often used inside of byobu on a command line that also make liberal use of the f-keys are htop and mc. I suppose I will be adding alsamixer to that list. The commonly understood workaround is to temporarily disable your F-key bindings while you're using alsamixer/htop/mc, and then re-enable them when you're done. You can easily toggle the f-key bindings on and off with ctrl-a-! (where ctrl-a is your chosen escape sequence).

See also Bug #589016, where I just added a visual queue to this toggle, which will switch the Menu:<F9> to and from Menu:<^a-@> when you toggle.

Hope that helps. I think that's about the best I can do with this bug. I'll probably need to mark this won't-fix or convert to a question.

Best Dustin Kirkland  (kirkland) said : #3

Hey Brian-

That's a tough one ...

We tried to bind all of the F-keys in Byobu that weren't already taken in gnome-terminal and konsole. This basically excluded byobu from using:

# F1 | 'help' in gnome-terminal
# F10 | 'toolbar' in gnome-terminal
# F11 | 'fullscreen' in gnome-terminal

However, I respect your question, and these comes up from time to time. Two programs which are often used inside of byobu on a command line that also make liberal use of the f-keys are htop and mc. I suppose I will be adding alsamixer to that list. The commonly understood workaround is to temporarily disable your F-key bindings while you're using alsamixer/htop/mc, and then re-enable them when you're done. You can easily toggle the f-key bindings on and off with ctrl-a-! (where ctrl-a is your chosen escape sequence).

See also Bug #589016, where I just added a visual queue to this toggle, which will switch the Menu:<F9> to and from Menu:<^a-@> when you toggle.

Brian Murray (brian-murray) said : #4

I wonder if there is some way something informative could be printed on the console like "detached because you pressed F6". I think this would be a less jarring experience.

Brian Murray (brian-murray) said : #5

Thanks Dustin Kirkland, that solved my question.