Brasero "Error reading video DVD (fatal error in vts css key)"

Asked by Joshua Fallaw on 2009-04-11

I was using Brasero to copy a two-disc DVD movie. I right click the DVD on my desktop, choose 'open with disc copier', choose my directory, leaving all options default, and hit 'copy'. The first disc copied perfectly with no errors, but when I try to copy the second disc, I get the error:

"Error reading video DVD (fatal error in vts css key)"

Here is the output of the log that it gives me:

<code>
Checking session consistency (brasero_burn_check_session_consistency burn.c:1905)
BraseroDvdcss called brasero_job_get_action
BraseroDvdcss called brasero_job_get_action
BraseroDvdcss called brasero_job_get_current_track
BraseroDvdcss called brasero_job_set_output_size_for_current_track
BraseroDvdcss stopping
BraseroDvdcss called brasero_job_get_action
BraseroDvdcss called brasero_job_get_session_output_size
BraseroDvdcss output set (IMAGE) image = /home/joshua/Videos/LOTR-Fellowship-D2.iso toc = none
BraseroDvdcss called brasero_job_get_action
BraseroDvdcss called brasero_job_set_use_average_rate
BraseroDvdcss called brasero_job_set_current_action
BraseroDvdcss called brasero_job_get_current_track
BraseroDvdcss called brasero_job_error
BraseroDvdcss finished with an error
BraseroDvdcss asked to stop because of an error
 error = 1
 message = "Error reading video DVD (fatal error in vts css key)"
BraseroDvdcss stopping
Session error : Error reading video DVD (fatal error in vts css key) (brasero_burn_record burn.c:2599)
</code>
It's really weird because these are two parts of the same movie- one should not be any different than the other. I have the latest libdvdcss installed. I've tried the few suggestions I've found here and with Google searches, but so far, it seems that Brasero is simply being picky about which DVD to copy. I am copying the LOTR extended edition boxed set. There are 11 DVDs that come with it. After further trial I found that some will copy, some won't. It just seems really strange since they are all a part of the same set. Any other suggestions? Or, can someone point me to a (gdk-based) application that will copy all my DVDs? Thanks! And just let me know if there are any logs or whatever that I should also post!

I should also note that all the DVDs play fine, using totem-xine.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu brasero Edit question
Assignee:
No assignee Edit question
Last query:
2009-05-18
Last reply:
2009-06-03
Joshua Fallaw (jfallaw) said : #1

Update- I dl'd and installed K3B and tried with it. Same error- failed to retreive CSS keys.

Hans Spaans (hspaans) said : #2

A lot of DVDs are encrypted and you need to package "libdvdcss2" for that. Please have a look at http://www.medibuntu.org/ for more information how to install this.

Joshua Fallaw (jfallaw) said : #3

Sorry, my post was not very clear or well organized. I already stated that I had the latest libdvdcss (aka libdvdcss2) installed. The problem seems to be either with libdvdcss2 or some other css related library, as the error is specific to css and is the same error that one would get if libdvdcss2 was not installed. Perhaps dvd manufacturers have better encryption methods these days and libdvdcss2 needs to be upgraded by the developers? Or maybe it's something to do with Jaunty, because I never had the problem in Intrepid. anyways, thanks for the post!

Joshua Fallaw (jfallaw) said : #4

Update- I am able to copy them using: dd if=dvd of=destination bs=2048 conv=notrunc

I also have this problem - Same error message in Brasero

Reproduced on Jaunty fresh install - with libdvdcss2 and w32codecs installed from mediabuntu repo

Copy works using dd

same here with 64bit jaunty, some dvds work, some not. dd works.

Same behavior on Jaunty 64bit! And I was unable to copy using dd (dd if=/dev/sr0 of=/home/tmoreira2020/XPTO.iso bs=2048 conv=notrunc) any clues??

answers (answersguy) said : #8

I'm using a 64-bit install of Ubuntu 9.04 (Jaunty) and Brasero 2.26.1 - same issue and error messages with libdvdcss2 and w64codecs installed. While not an elegant solution, using dd to copy the DVD seems to work fine.

Joshua Fallaw (jfallaw) said : #9

OK, I figured out what is going on. After trying various things, I decided to re-run

sudo /usr/share/doc/libdvdread4/install-css.sh

The terminal output informed me that it was 'selecting previously deselected package libdvdcss2'. Everything worked fine after that. But then, about a week later, it stopped working again. I had done nothing in the interim other than update my system with aptitude. Well, on a whim, i ran

sudo /usr/share/doc/libdvdread4/install-css.sh

again- got the same message: 'selecting previously deselected package libdvdcss2'. What's happening is that EVERY TIME I update my system, libdvdcss2 gets uninstalled somehow. This has happened about three times now. IDK why, but that's what's happening, because after every update, dvds stop playing and become impossible to copy until I run the install on libdvdread4 again. Weird. Any clues as to why this would happen?

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

davidc (daave-daave) said : #11

I am also experiencing this issue on an ubuntu 10.04 install even having run install-css.sh from libdvdread4, on a Lenovo ThinkPad W510 (if that matters)

yngens (foranycase) said : #12

Same issue here on Ubuntu 10.04 with Brasero Disk Burner. I wonder how I use dd if=dvd of=destination bs=2048 conv=notrunc? Command line? With what exact command?

Joshua Fallaw (jfallaw) said : #13

@yngens

DD (data description) is the name of the command. the "if" portion is the address of your dvd drive, and the "of" portion is where you want to copy the disk to. So something like

dd if=/dev/cdrom of=/home/joshua/myCD.iso bs=2048 conv=notrunc

would copy the image from the cdrom drive (/dev/cdrom) to my home folder (/home/joshua) with the name myCD.iso

Okay, I found three alternatives, displayed here from the worst to the best.

1/ Using dvdbackup :
$ dvdbackup -M
$ genisoimage -dvd-video -udf -o dvd.iso EXTRACTED_DVD/
But the dvd.iso file is not correctly readable on VLC and Totem (only MPalyer).

2/ Using dvdcpy (provided by ogmrip) :
$ dvdcpy -s blank -o dvd -m /dev/sr0
$ genisoimage -dvd-video -udf -o dvd.iso dvd/

3/ Using dd (be very careful!) :
$ dd if=/dev/sr0 of=/home/username/dvd.iso bs=2048 conv=sync,noerror

Matthew Ross (mattross65-1) said : #15

Hi, I had the same problem but my fix was correcting the region code on my DVD drive. I had recently changed the drive which I bought from China. I am in Australia. I installed "regionset" from the software centre in Natty and ran the program from terminal "sudo regionset". It asked me what region I wanted and I selected 4 which is the same as my dvd's. I then went to Brasero and copied the dvd to iso and the error disappeared.

I tried many other options, but this was the fix that worked for me. Cheers Matt :-)

Maybe I'm missing something obvious, but why does Brasero even need to think about CSS decoding when making a DVD disk image? As shown by the alternatives using dd, all that's needed is to transfer the bits from the DVD to the image file... right? Is the CSS key handling really technically needed to make the copy, or is it an attempt to be clever / enforce region restrictions?

Cheers,
Andy

Joshua Fallaw (jfallaw) said : #17

Seems like a safeguard to protect the developers from any legal issues. Not sure why they would bother, they could just include a disclaimer passing liability to the user.

ionospheric (berthold1) said : #18

I was able to copy all of the DVD's with the dd command
$ dd if=/dev/sr0 of=/home/username/dvd.iso bs=2048 conv=sync,noerror

(sometimes after some tweaking)

One DVD caused problems, but worked after running the script
sudo /usr/share/doc/libdvdread4/install-css.sh

One DVD did not even work after that. However, I had a DVD with I/O errors in the drive before trying. Once I rebooted, the same DVD allowed copying. Maybe the sr0 driver cache had some bad values in it. In any case, thanks for all the help-I am a lot less stressed out now when our little one starts chewing on our DVD's!