libboost-locale1.54-dev and libboost-filesystem1.54-dev seem to depend on different versions of libboost1.54-dev

Asked by SmashLink

I was trying to compile Blender from source.

The script for solving dependencies is trying to install libboost-locale1.54-dev and libboost-filesystem1.54-dev but they have unmet dependencies: -locale depends on libboost1.54-dev (= 1.54.0-4ubuntu3) and -filesystem depends on libboost1.54-dev (= 1.54.0-4ubuntu3.1).

Is there a way to solve this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu boost1.54 Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

What is the output of:

lsb_release -a; uname -a; apt-cache policy libboost-locale1.54-dev libboost-filesystem1.54-dev

Thanks

Revision history for this message
SmashLink (migargallova) said :
#2

lsb_release -a:
  No LSB modules are available.
  Distributor ID: elementary OS
  Description: elementary OS Freya
  Release: 0.3.2
  Codename: freya

uname -a:
  Linux sat 3.19.0-51-generic #58~14.04.1-Ubuntu SMP Fri Feb 26 22:02:58 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

apt-cache policy libboost-locale1.54-dev libboost-filesystem1.54-dev:
  libboost-locale1.54-dev:
    Installed: 1.54.0-4ubuntu3
    Candidate: 1.54.0-4ubuntu3
    Version table:
   *** 1.54.0-4ubuntu3 0
          500 http://dk.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
          100 /var/lib/dpkg/status
  libboost-filesystem1.54-dev:
    Installed: (none)
    Candidate: 1.54.0-4ubuntu3.1
    Version table:
       1.54.0-4ubuntu3.1 0
          500 http://dk.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
       1.54.0-4ubuntu3 0
          500 http://dk.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#3

Elementary OS is not supported by the Ubuntu community in any way. It's support community is entirely separate from Ubuntu's. None of the "Ubuntu based" distributions are supported by the Ubuntu community.

I suggest you post on the Elementary-os forum here:
https://elementaryforums.com/index.php

Revision history for this message
SmashLink (migargallova) said :
#4

Thanks actionparsnip, that solved my question.

Revision history for this message
Manfred Hampl (m-hampl) said :
#5

@Smashlink: You might be missing the trusty-updates/universe repository, but you should check that with elementary support.