Why is libboost-program-options1.55.0 untrusted?

Asked by markling on 2016-01-14

When installing the tool glogg, my system says:

glogg libboost-program-options1.55.0 is an untrusted package from unauthenticated sources.

Why is this?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu boost-defaults Edit question
Assignee:
No assignee Edit question
Last query:
2016-02-10
Last reply:
2016-02-10
Manfred Hampl (m-hampl) said : #1

Please provide the output of the diagnostic commands

uname -a
lsb_release -crid
apt-cache policy glogg libboost-program-options1.55.0

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

markling (markling) said : #3

Linux bonzo 3.19.0-47-lowlatency #53-Ubuntu SMP PREEMPT Mon Jan 18 15:42:19 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Distributor ID: Ubuntu
Description: Ubuntu 15.04
Release: 15.04
Codename: vivid

glogg:
  Installed: 1.0.2-1
  Candidate: 1.0.2-1
  Version table:
 *** 1.0.2-1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status
libboost-program-options1.55.0:
  Installed: 1.55.0+dfsg-3ubuntu2
  Candidate: 1.55.0+dfsg-3ubuntu2
  Version table:
 *** 1.55.0+dfsg-3ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

Manfred Hampl (m-hampl) said : #4

What action did you perform to get that "unauthenticated" warning?

markling (markling) said : #5

I was installing the tool, glogg.

Manfred Hampl (m-hampl) said : #6

Please provide the output of the command

sudo apt-get update

markling (markling) said : #7

What all of it?

It's returns a long list of hits on http://archive.ubuntu.com vivid

Manfred Hampl (m-hampl) said : #8

Yes, the whole output of that command please (just use copy/paste).

markling (markling) said : #9

I'm not sure I want to publish the whole list. Can we narrow it down a bit? What should we be looking for?

There are one or two errors (I can't be certain the main amd64 Packages error wasn't there when I did this the other day):

Get:1 http://archive.getdeb.net vivid-getdeb/apps amd64 Packages [64.4 kB]
Err http://ppa.launchpad.net vivid/main amd64 Packages
  404 Not Found
Err http://ppa.launchpad.net vivid/main i386 Packages
  404 Not Found

...
Fetched 130 kB in 51s (2,506 B/s)

W: Failed to fetch http://ppa.launchpad.net/freefilesync/ffs/ubuntu/dists/vivid/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/freefilesync/ffs/ubuntu/dists/vivid/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

Manfred Hampl (m-hampl) said : #10

I am mainly interested in warnings and error messages.

It is quite possible that there were no error messages a few days ago.
The support for Ubuntu 15.04 vivid has ended last week, and the repositories for this release are being removed.

You should care for a release upgrade to a supported Ubuntu release (in your case probably 15.10 wily) in due course.

Can you help with this problem?

Provide an answer of your own, or ask markling for more information if necessary.

To post a message you must log in.