libbx_voodoo.so doesn't seem to exist

Asked by p kirkham on 2019-05-22

disco, x86_64

bochs --help features shows voodoo as if it were compiled with voodoo support
but apt-file cannot find libbx_voodoo.so in any package

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bochs Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-05-22
Last query:
2019-05-22
Last reply:
2019-05-22

What is the output of:

apt-cache policy bochs; lsb_release -a; uname -a

Thanks

p kirkham (pkirk08) said : #2

bochs:
  Installed: 2.6.9+dfsg-2build1
  Candidate: 2.6.9+dfsg-2build1
  Version table:
 *** 2.6.9+dfsg-2build1 500
        500 http://us.archive.ubuntu.com/ubuntu disco/universe amd64 Packages
        100 /var/lib/dpkg/status
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.04
Release: 19.04
Codename: disco
Linux patrick-Precision-T1600 5.0.0-15-generic #16-Ubuntu SMP Mon May 6 17:41:33 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

https://packages.ubuntu.com/search?suite=disco&arch=any&mode=filename&searchon=contents&keywords=voodoo

I cannot see libbx_voodoo.so in any package in any currently supported Ubuntu release.

Best Manfred Hampl (m-hampl) said : #5

Looking at the buildlog of the latest bochs version in Ubuntu https://launchpad.net/ubuntu/+source/bochs/2.6.9+dfsg-2build1/+build/16277513/+files/buildlog_ubuntu-disco-amd64.bochs_2.6.9+dfsg-2build1_BUILDING.txt.gz I see that libbx_voodoo.so.0.0.0 is created during the build process, but apparently is not put into any of the .deb packages that are created (it's not listed in the bochs.install file).

A quick check shows the same situation also for the packages in Debian sid and buster.

In my opinion this is worth a discussion with the developers.
I suggest that you create a bug report, maybe also in the Debian bug system.

p kirkham (pkirk08) said : #6

Thanks Manfred Hampl, that solved my question.