Xubuntu 9.10 bluetooth mouse HP 5310m

Asked by remerson on 2009-12-28

Hi,

I've recently installed Xubuntu 9.10 on a new HP 5310m notebook.

I've got a new Logitech bluetooth mouse that I'm trying to use but can't seem to work out how to pair it.

From following the instructions listed and some Googling, I think I should either a) (ideally) have a bluetooth icon on the right of the top panel I can use which should give me a GUI wizard for pairing etc. or b) do this via the command line

For (a) I don't have any such icon nor can I find anything about managing bluetooth devices in any of the menus/settings. How can I enable this? What am I missing?

For (b) I can run 'hcitool scan' which seems to detect my mouse properly (giving me hope that the driver etc. is all working correctly) e.g.

hcitool scan
Scanning ...
 00:aa:bb:cc:19:93 Logitech Bluetooth Mouse M555b

But the rest of the instructions require me to run "hidd" which isn't installed - I guess this refers to some older Ubuntu version/package.

Ideally, I'd like to get the GUI method working!

Any help very much appreciated.

uname -a
Linux 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:02:15 UTC 2009 x86_64 GNU/Linux

hciconfig -a
hci0: Type: USB
 BD Address: 00:aa:bb:cc:64:72 ACL MTU: 1021:8 SCO MTU: 64:1
 UP RUNNING PSCAN
 RX bytes:1039 acl:0 sco:0 events:37 errors:0
 TX bytes:1355 acl:0 sco:0 commands:35 errors:0
 Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x79 0x83
 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
 Link policy: RSWITCH HOLD SNIFF PARK
 Link mode: SLAVE ACCEPT
 Name: 'spire-0'
 Class: 0x4a010c
 Service Classes: Networking, Capturing, Telephony
 Device Class: Computer, Laptop
 HCI Ver: 2.1 (0x4) HCI Rev: 0x132 LMP Ver: 2.1 (0x4) LMP Subver: 0x4203
 Manufacturer: Broadcom Corporation (15)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
remerson
Solved:
2009-12-28
Last query:
2009-12-28
Last reply:
2009-12-28
remerson (ubuntu-remerson) said : #2

Thanks - this was one of the first guides I found too.

But it doesn't work - this is where I fall down:

sudo hidd --search
sudo: hidd: command not found

So I guess this method is for an older version or I am missing some package?

I have tried from here too:

https://help.ubuntu.com/community/BluetoothSetup

This says that: "The BlueTooth notification icon starts by default, but sometimes the service does not." But for me it's the other way around - I think the service is running but get no icon or anything...

remerson (ubuntu-remerson) said : #3

I think I've cracked it.

I read this here:

http://ubuntuforums.org/showthread.php?t=1029852

And needed to install this:

http://ubuntuforums.org/showthread.php?t=1029852

Then I ran 'bluetooth-applet' - this got me the GUI up and the rest works flawlessly.

I guess Xubuntu is missing this by default?! Anyway - working great now.

Many thanks again,