Bluetooth USB adapter Belkin F8T008 does not work

Asked by Uwe Geuder on 2009-07-29

I tried the use my (couple of years old) Belkin Bluetooth USB adapter F8T008 with Intrepid, but it does not work. I also tried shortly on Jaunty, but the issue seems to be the same. The hardware is 0a5c:200a Broadcom Corp Bluetooth dongle (from lsusb)

According to the logs many (all???) HCI commands fail with timeout. This happens already when bluetoothd tries to initialize it.

I checked the Web and the most common answer for problems with Belkin USB adapters is to blacklist the pegasus driver.
However, that is not my problem because the "Generic Bluetooth USB driver ver 0.3" is loaded for my adapter regardless whether I backlist pegasus or not.

Any ideas?

P.S. I'm currently unable to post exact logs. I'm on holidays and depending on my mobile phone. Without Bluetooth my Ubuntu is not connected to anything :(

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Last query:
2009-07-29
Last reply:
2009-07-30

Some people on this bug:

https://bugs.launchpad.net/ubuntu/+bug/289836

Say that adding:

deb http://ppa.launchpad.net/blueman/ubuntu jaunty main

to

/etc/apt/cources.list

and installing blueman makes it work ok.

Can you help with this problem?

Provide an answer of your own, or ask Uwe Geuder for more information if necessary.

To post a message you must log in.