Bluetooth service discovery not working

Asked by Rohan on 2009-02-13

I am using Bluetooth dongle in my Acer Aspire Laptop, after successfully installed ubuntu 8.04 found my dongle and bluez applet works well. when i try to pair with sony ericssion z550 it had successfully paired but failed to discover a service from both side. and also not able to pair with htc.

When i tried to use this command, sdptool browse my-phone-MAC-address. said failed to discovered but the phone is paired successfully.

When i tried to use this command, sdptool browse local, was found all service locally available.

Help me to connect to bluetooth dailup? with my phone htc and sony ericssion z550i

and also need to connect htc to activesync via usb

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-16
Last reply:
2009-02-16
george (gk-joimail) said : #1

Hi

You might try this, it worked for me.

go to Applications/Accessories/Terminal
in terminal type

sudo /etc/init.d/bluetooth restart

Enter, then close and your discovery should find your phone.

George

Rohan (rohanr0055) said : #2

Hi george,

Thanks for your answer. But i already tried it, that was not work for me. i need more help.....

george (gk-joimail) said : #3

Rohan

Go to add/remove programs and check to see if you have Blue tooth Analyzer installed, you most likely do, but just check. I would also go to their website for help.

http://www.bluez.org/

other than that, I'm sorry I'm also at a loss.

George

Rohan (rohanr0055) said : #4

Yes, bluetooth analyzer is available and its already install. and i refered that website and download the latest realse of bluez 4.30. now, the problem increase... i mean, i dont know how to install that. which comes with source code there is no install package.

george (gk-joimail) said : #5

download the file to your desktop. You should see a small circle with a lock. Click on the icon, click on properties, then permission all three access from read only to read and write. check allow executing file as program, close then right click on file again a choose archive mounter or gksudo under "other applications"

Can you help with this problem?

Provide an answer of your own, or ask Rohan for more information if necessary.

To post a message you must log in.