Bluetooth/main.conf could not be stored

Asked by Dieter Klaus on 2009-02-07

Because I cannot connect my SE K800i to my SONY VAIO via Bluetooth, I try to change the file
bluetooth/main.conf: class 0x000100 -> 0x100100. I can do it but not store the file (no rights).
I'm a newcomer in Linux/Ubuntu 8.10. Thanks for any help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
Huygens
Solved:
2009-02-08
Last query:
2009-02-08
Last reply:
2009-02-07
Best Huygens (huygens-25) said : #1

The file you try to modify needs administrative privilege to be modified. The most simple way I know to modify it with those kind of privilege is the following:

At the top of your screen, you have a menu call "Applications" (in English). Under it, you have a section called "Accessories". In this section, you have a tool call a "Terminal". Click on it. Do not worry, it is going to be easy ;-)
Once it is open copy the following line and paste it in the Terminal (use the menu "Edition" -> "Paste")
gksudo gedit

Now press the keyboard key "Enter". A window will prompt you for your password, enter it. Now you should have gedit launched and it has the rights to modify administrative files. So be careful with it ;-)
But I guess you know your way now. Go in the File menu and select Open. Open your file and modify it, you can now save it too!

Dieter Klaus (dh-pool537) said : #2

Thanks Huygens, that solved my question.

Huygens (huygens-25) said : #3

I'm happy it did :-)