Bluetooth PAN does not work after upgrade bluetooth/bluez to 4.12

Asked by Kitt Tientanopajai on 2008-10-08

Binary package hint: bluez-utils

I've just upgrade bluez to 4.12-0ubuntu2 and found that pand is missing. I've learned that pand and older utils have been removed from bluez 4.12. Is there any tools/config in 4.12 to provide bluetooth PAN service ? (bluetooth mouse, obex push work fine).

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
Kitt Tientanopajai
Solved:
2008-12-07
Last query:
2008-12-07
Last reply:
2008-10-26
Mario Limonciello (superm1) said : #1

You should have a pan0 ethernet device already.

Look at

ifconfig pan0

Configure it using standard ethernet tools.

Mario Limonciello (superm1) said : #2

converting this to a quesion as it's a configuration issue

Kitt Tientanopajai (kitty) said : #3

Thanks Mario,

Yes, I have pan0, but how can I use pan0 to connect to my mobile phone ? dhclient does not seem to work though.

Mario Limonciello (superm1) said : #4

Are you sure pan is what you are looking for, not DUN? PAN is generally used in bluetooth networks between PC's I thought.

Kitt Tientanopajai (kitty) said : #5

I think it's PAN. With older version of bluez (e.g. 3.36), I would use

pand -c XX:XX:XX:XX:XX:XX

to connect to my mobile phone (with Internet Sharing through Bluetooth PAN). If things went right, bnep0 interface would be up, and I can just dhclient bnep0 to get an IP address from my mobile phone.

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Kitt Tientanopajai (kitty) said : #7

Just to close this question properly

I've just found that pand is provided by bluez-compat (along with hidd and dund). I've tested and it works great.

Kitt Tientanopajai (kitty) said : #8

Problem solved by install bluez-compat package