8.04 Bluetooth adapter detected but not found by Manager

Asked by Clive on 2008-08-28

Hi,

I posted this on the forums but got few replies so I am trying here.
I am very new to Linux and Ubuntu.
Bluetooth Manager is not recognizing an adapter is present, no icon appears and I can do nothing except at the command line level, even though the system says there is one and I can work with it from a console as below:
clive@clive-laptop:~$ hciconfig
hci0: Type: USB
BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
DOWN
RX bytes:0 acl:0 sco:0 events:0 errors:0
TX bytes:0 acl:0 sco:0 commands:0 errors:0

clive@clive-laptop:~$ hciconfig hci0 up
Can't init device hci0: Permission denied (13)
clive@clive-laptop:~$ sudo hciconfig hci0 up
[sudo] password for clive:
clive@clive-laptop:~$ hciconfig
hci0: Type: USB
BD Address: 00:1B:10:00:12:B5 ACL MTU: 1017:8 SCO MTU: 64:0
UP RUNNING
RX bytes:348 acl:0 sco:0 events:11 errors:0
TX bytes:38 acl:0 sco:0 commands:11 errors:0

clive@clive-laptop:~$

The device at system start is always down but comes up with no issues. I can do a scan once it is up:

clive@clive-laptop:~$ hcitool scan
Scanning ...
00:1C:CC:C6:F6:15 BlackBerry 8707
clive@clive-laptop:~$

I can find any other device I turn on in range.
My hcid.conf file is posted below I made changes based on some threads I read:

# HCId options
options {
# Automatically initialize new devices
autoinit yes;

# Security Manager mode
# none - Security manager disabled
# auto - Use local PIN for incoming connections
# user - Always ask user for a PIN
#
security auto;

# Pairing mode
# none - Pairing disabled
# multi - Allow pairing with already paired devices
# once - Pair once and deny successive attempts
pairing multi;

# Default PIN code for incoming connections
passkey "1111";
pin_helper /usr/bin/bluez-pin;

}

# Default settings for HCI devices
device {
# Local device name
# %d - device id
# %h - host name
# name "%h-%d";
name "clive";

# Local device class
class 0x000100;

# Default packet type
#pkt_type DH1,DM1,HV1;

# Inquiry and Page scan
iscan enable; pscan enable;
discovto 0;

# Default link mode
# none - no specific policy
# accept - always accept incoming connections
# master - become master on incoming connections,
# deny role switch on outgoing connections
lm accept;

# Default link policy
# none - no specific policy
# rswitch - allow role switch
# hold - allow hold mode
# sniff - allow sniff mode
# park - allow park mode
lp rswitch,hold,sniff,park;
}

I hope this gives enough information for someone to help.

Best regards,
Clive

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
Clive
Solved:
2008-08-30
Last query:
2008-08-30
Last reply:
Clive (clivemunday) said : #1

Can anyone help me to solve this Bluetooth problem I simply cannot get Bluetooth Manager to find the adapter although it is present and detected by the system.

Best regsrds,
Clive

Clive (clivemunday) said : #2

I have fixed this issue.

_Milk (wheresmichael) said : #3

Hey Clive,
   I have the same problem. You're the first person I've run across with this issue. How did you fix it? If I reinstall bluez-utils it runs a startup command and everything works fine, but I can't figure out which command it is running.

Help!

_Milk (wheresmichael) said : #4

I forgot to check the "email me" box

Clive (clivemunday) said : #5

Hi _Milk,

Take a look at this forum posting it expalins what I did. If you need more help let me know.

http://ubuntuforums.org/showthread.php?t=898423&highlight=bluetooth

Best regards,
Clive

_Milk (wheresmichael) said : #6

It worked! Thanks Clive.