Bluetooth Stops Working 8.04

Asked by Benjamin Prosnitz on 2008-06-16

Everytime I restart my computer, my bluetooth mouse doesn't work and the bluetooth icon doesn't appear on the status bar. Restarting the bluetooth service doesn't do anything.

What does fix it (temporarily) is reinstalling all bluez* and *bluetooth* packages. Bluetooth then works until I restart the computer, at which point nothing works again.

This is repeatable.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
Benjamin Prosnitz
Solved:
2008-06-16
Last query:
2008-06-16
Last reply:
2008-06-16
Benjamin Prosnitz (aetherane) said : #1

I want to add that this did not happen until a few days ago, and during this time I had not changed anything involving the setup of my computer, or bluetooth in particular.

Harvey Muller (hlmuller) said : #2

Benjamin,

I use a Microsoft bluetooth mouse. Is yours Microsoft also? And do you ever reassociate the mouse with a different laptop, or a different distribution?

Those are conditions under which I have to re associate the mouse in Ubuntu. To re associate the mouse, you have to disconnect the mouse and delete it from Bluetooth Properties. And then re associate it.

I cannot test in Hardy at present, because I just upgraded to Intrepid to take a look around. So I don't know if there is a verifiable bug with the bluetooth input service.

Benjamin Prosnitz (aetherane) said : #3

It is a Microsoft mouse, a Microsoft Wireless Laser Mouse 8000. I have only associated it with the laptop I use it on.

I suspect that it is not a problem with Bluetooth Mice or this specific mouse, because the Bluetooth icon (which is set to appear only when a Bluetooth adapter is present) does not appear until I reinstall the bluetooth packages - and at the same time the bluetooth mouse works.

So it seems like, for whatever reason, the Bluetooth adapter is disappearing. I would be happy to give more information on the adapter, but I don't now what commands to run. IIRC it is a Dell Bluetooth 350 module that I am using.

Benjamin Prosnitz (aetherane) said : #4

Ok. I solved the problem. It appears that the service wasn't starting automatically for some reason.

Tony Mugan (tmugan) said : #5

I had a similar issue and fixed it by actually permanently uninstalling the bluez libraries.

Until I did that, I had to unplug the logitech bluetooth adapter and plug it back in again on every reboot to get it working.

The bluez packages were actually conflicting with the logitech driver I guess.