Programmes not working after update from 12.04LTS to 12.10

Asked by frederik on 2012-11-21

Hi,

I did update one of mine computers from ubuntu 12.04LTS to 12.10. The installation upgrade was going good, but after first start followed probems I did had.

Wireless Keyboard + Mouse (Bluetooth)
------------------------------------------------------
Keyboard MX5500 Logitech wouldn't work not more after ugrade to 12.10!

Solution:
Did open terminal konsole and did followed commands:
1. gksudo gedit /lib/udev/rules.d/97-bluetooth-hid2hci.rules
2. After openening file change:
Look for the line under ”# Logitech devices” that starts with:
KERNEL==“hiddev*”
and change it to:
KERNEL==“hidraw*”
3. Type following command: hcitool dev ==> You get the MAC adress from your USB stick Logitech keyboard.
4. Press bleutooth connection button from keyboard and type then following command ==> hcitool scan
You get now MAC adress from Keyboard.
5. Type following command ==> sudo apt-get install bluez-compat
6. Type following command ==> sudo hidd --connect XX:XX:XX:XX:XX:XX (The x are the MAC adress from your keyboard)!

After some seconds, everything works back normal. Strange that it was working monts & months good on 12.04LTS and suddenly after upgrade not working annymore!
But most important is, that the problem was solved!

TEST programmes who are standing on UNITY BAR (all programmes did work on 12.04LTS before upgrade to 12.10):
----------------------------------------------------------------------------------------------------------------------------------------------------------------
1.
Konsole => not working ; after test de-install and install again, result not working. Then downloading from website: http://www.ubuntuupdates.org/package/core/quantal/universe/base/konsole
and installing again. Result is still the same. Not working annymore? No errors - reason???

2.
KCalc => Did had same problem with Kcalc. But did work after installing from the website: http://www.ubuntuupdates.org/package/core/quantal/universe/proposed/kcalc

3.
Evolution: Evolution was working perfect before on 12.04LTS. After upgrade it was not working directly. I did need to reconfigure POP - SMTP -etc... again. Then it did work again. But I can't get it launched standard from mine taskbar? Starting it from the Unity bar was no problem. After setup the Thunderbird mail client, I did had back the envelop icon in Taskbar and like before I did had with the 12.04LTS version.

Other problems for moment not found yet. It seems to be good I was testing it first on mine test computer before to install it on mine work computer.

I don't know if I did do some things wrong when it was installing the upgrade? Most of things were total automatic. Errors I did not have!

Annyway, ubuntu rocks :)

Best Regards,
Frederik

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-21
Last reply:
2012-11-22
Warren Hill (warren-hill) said : #1

I would be tempted to backup then do a clean reistall

backup the following folders including hidden files and folders /home /var /etc

Once done re-install and copy the /home folder back. You may not need /var and /etc so don't copy these back. If you are having any problems after the update let us know the details and you may need to copy certain files or folders back but not all.

frederik (frederik-mattelaere) said : #2

Hi,

Thanx for the advice.

The computer who is upgraded to 12.10 is a hard-disk I use to test the upgrades before I install them on mine notebook (working computer).

I just check what is working after upgrade and not, what I need to change etc...
For mine working computer I will stay on the 12.04LTS and update it every week.

With mine test computer I also work, but if it suddenly crash, all documents are on mine working computer.

Above I did put here on the bug forum, because other people had same problem. So, it can only help the developpers, to see what can go wrong or what I did do to solve it ;)

For problems above, I will search until I found solutions and will update then this page, just like I already did do for the wireless keyboard!

Thanx & Best Regards,
Frederik

Can you help with this problem?

Provide an answer of your own, or ask frederik for more information if necessary.

To post a message you must log in.